[postgreSQL 84] sorry, could not install postgreSQL - but I HAVE IT !
Results 1 to 6 of 6
  1. #1
    Junior Member
    Join Date
    Sep 2021
    Posts
    3

    Default [postgreSQL 84] sorry, could not install postgreSQL - but I HAVE IT !

    I have postgres 13, pg admin
    1.PNG

    4.PNG5.PNG6.PNG

    all up and runing

    7.PNG
    Attached Images Attached Images
    • File Type: png 2.PNG (14.5 KB, 2 views)
    • File Type: png 3.PNG (15.6 KB, 2 views)

  2. #2
    You're out! udbrky's Avatar
    Join Date
    Jul 2008
    Posts
    20,844

    Default

    We do not update the newer Postgres versions, since we stopped supporting HM2.

    Install 8.4, then uninstall it afterwards.
    Regards udbrky (Chris)

  3. #3
    Junior Member
    Join Date
    Sep 2021
    Posts
    3

    Default

    Quote Originally Posted by udbrky View Post
    We do not update the newer Postgres versions, since we stopped supporting HM2.

    Install 8.4, then uninstall it afterwards.
    I was hard to find the postgres 84, but after 3 days, I find... ty... so hard, I formated my computer dudes, was so sick why I could not use newer versions of posgres, pay attention to that .exe conports !

  4. #4
    Junior Member
    Join Date
    Sep 2021
    Posts
    3

    Exclamation

    Quote Originally Posted by fraktool View Post
    I was hard to find the postgres 84, but after 3 days, I find... ty... so hard, I formated my computer dudes, was so sick why I could not use newer versions of posgres, pay attention to that .exe conports !
    BTW !!!
    The support of the postgres site reply:

    https://www.postgresql.org/docs/8.4/install-win32.html

    "It is recommended that most users download the binary distribution for Windows, available as a Windows Installer package from the PostgreSQL website. Building from source is only intended for people developing PostgreSQL or extensions.

    There are several different ways of building PostgreSQL on Windows. The complete system can be built using MinGW or Visual C++ 2005. It can also be built for older versions of Windows using Cygwin. Finally, the client access library (libpq) can be built using Visual C++ 7.1 or Borland C++ for compatibility with statically linked applications built using these tools.

    Building using MinGW or Cygwin uses the normal build system, see Chapter 15 and the specific notes in Section 15.8.5 and Section 15.8.2. Cygwin is not recommended and should only be used for older versions of Windows where the native build does not work, such as Windows 98."

  5. #5
    You're out! udbrky's Avatar
    Join Date
    Jul 2008
    Posts
    20,844

    Default

    8.4 is included in HM2's installation, so choosing to install it when prompted is what I assumed you were going to do.
    Regards udbrky (Chris)

  6. #6
    Junior Member
    Join Date
    Jul 2014
    Posts
    14

    Default

    postgres 13 seems working ok with hm2, but default authentication has to be tweaked.

    in addition to basic parameters:
    port 5432
    user postgres
    password postgrespass

    either plaintext auth method has to be enabled (in ph_hba.conf):
    host all all 127.0.0.1/32 password

    or md5 (in ph_hba.conf ):
    host all all 127.0.0.1/32 md5

    but to md5 auth to work, there also must be md5 password hashes stored inside postgres. and by default they are scram-sha-256.

    so password_encryption (in postgresql.conf) has to be:
    password_encryption = md5

    after that applied, password must be reset to 'postgrespass' again to update hash.


    PostgreSQL Tuning function in HM2 will not work with v13. That is what it changes in postgresql.conf:

    ### REPLACED ### shared_buffers = 128MB # min 128kB
    # (change requires restart)
    ### REPLACED ### #work_mem = 4MB # min 64kB
    ### REPLACED ### #hash_mem_multiplier = 1.0 # 1-1000.0 multiplier on hash table work_mem
    ### REPLACED ### #maintenance_work_mem = 64MB # min 1MB
    ### REPLACED ### #autovacuum_work_mem = -1 # min 1MB, or -1 to use maintenance_work_mem
    ### REPLACED ### #logical_decoding_work_mem = 64MB # min 64kB
    ### REPLACED ### #wal_buffers = -1 # min 32kB, -1 sets based on shared_buffers
    # (change requires restart)
    ### REPLACED ### #commit_delay = 0 # range 0-100000, in microseconds
    ### REPLACED ### #checkpoint_completion_target = 0.5 # checkpoint target duration, 0.0 - 1.0
    ### REPLACED ### #effective_cache_size = 4GB

    shared_buffers = 1024MB
    effective_cache_size = 1024MB
    work_mem = 16MB
    maintenance_work_mem = 16MB
    commit_delay = 10000
    max_wal_size = 1800MB # here it places checkpoint_segments=128, but that option is deprecated since v9.5, max_wal_size is its equivalent.
    checkpoint_completion_target = 0.9
    wal_buffers = 2MB

Similar Threads

  1. Combo Installer: "Sorry, could not install PostgreSQL"
    By Pureman in forum Manager General
    Replies: 61
    Last Post: 07-03-2013, 09:27 PM
  2. "sorry,could not install PostgreSQL"
    By yangpenger in forum Manager General
    Replies: 14
    Last Post: 05-09-2011, 07:06 PM
  3. Error: Sorry, could not install PostgreSQL
    By GeleHaas in forum Manager General
    Replies: 15
    Last Post: 07-20-2010, 10:21 PM
  4. Sorry could not install PostgreSQL
    By 888top in forum Manager General
    Replies: 1
    Last Post: 03-15-2010, 06:10 AM
  5. Combo installer : Sorry, could not install PostgreSQL
    By ieatdonks in forum Manager General
    Replies: 1
    Last Post: 02-02-2010, 09:04 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •