Bugs:Error: Cannot start thread: error writing TLS error 87
Results 1 to 4 of 4
  1. #1
    Junior Member
    Join Date
    Mar 2020
    Posts
    8

    Default Bugs:Error: Cannot start thread: error writing TLS error 87

    "Bugs:Error: Cannot start thread: error writing TLS error 87"

    picture and logs as attached.

    Open HM3 and get this error, for both of two PC
    Attached Images Attached Images
    Attached Files Attached Files

  2. #2
    *** HM3! *** fozzy71's Avatar
    Join Date
    Sep 1971
    Location
    HM Support
    Posts
    31,074

    Default

    The error in your image is different than the error you described in your post. What does the error in your image translate to in English?

    It appears that our parser is crashing for some reason:

    Code:
    2021/02/22 20:23:40.096 [HM3 Main Thread:01] [HoldemManager3:NiniConfiguration:Load(37)] [Info] Config file does not exist, creating default config file.
    Possibly because you installed HM3 to a custom drive/path:

    Code:
    2021/02/22 20:23:40.170 [HM3 Main Thread:01] [HoldemManager3:StatService:.ctor(35)] [Info] construct StatsResource (path: E:\Holdem Manager 3 new\Holdem Manager 3\StatsDictionary.hmsd)
    Try to reinstall HM3 completely to the default installation path on your C:\ drive to see if that helps:

    - Please try to uninstall HM3 from your Control Panel - Programs and Features menu.
    - Rename your C:\Users\UserName\AppData\Roaming\Max Value Software\Holdem Manager\ folder*. You can delete this later if we don't ask you to send it to us or copy/paste the contents back to where they were originally.
    * If you can't see it, turn off the windows option that is hiding that directory. http://faq.holdemmanager.com/questio...es+in+Windows+
    - Delete C:\Program Files (x86)\Holdem Manager 3\ if you see it.
    - ^^ Those paths are likely on your E:\ drive instead of the C:\ drive based on that code/error above.
    - Restart your computer.
    - Download and install HM3 again from this link - https://www.holdemmanager.com/downlo...channel=stable

    It also looks like you do not have any auto import folders configured for any sites yet in your config files.

    Try to setup your auto import folders properly in the HM3 - Tools - Site Settings... menu for your sites and move any files/folders you see in D:\HM3数据\PokerTime\ folder to the C:\HM3Archive folder.

    If you continue to have problems: Please create a support ticket via the 'Contact Support' link with a link to this thread and your forum username. Please reproduce the problem and attach a set of log files and a screenshot and detailed description of the issue in the support ticket you created.

  3. #3
    Junior Member
    Join Date
    Mar 2020
    Posts
    8

    Default

    HM3 0222.png

    sorry, I attached the wrong picture, this one should be correct

  4. #4
    *** HM3! *** fozzy71's Avatar
    Join Date
    Sep 1971
    Location
    HM Support
    Posts
    31,074

    Default

    Please follow the instructions in the post above.

    If that does not help make sure your computer time and time zone is properly configured:

    - Right-click your computer clock. Go to adjust date/time. Sync to the internet.
    - Make sure windows is fully updated until 'No New Important Updates are Found' (this may require multiple restarts and multiple 'check for updates'), including Internet Explorer (even if you use a different web browser).
    - Make sure that Daylight Savings Time is enabled if you live in a place that observes DST - https://superuser.com/questions/1053...orking/1053289

    If none of that helps please send us a new set of log files and screenshots in a support ticket as instructed above/below:

    Please create a support ticket via the 'Contact Support' link with a link to this thread and your forum username. Please reproduce the problem and attach a set of log files and a screenshot and detailed description of the issue in the support ticket you created.

    for us to review and if we don't see anything more clear in those logs we will send you a new internal beta version (that I can't post in the forums) with our updated parser and additional parser logging to see if it helps, and to send us better logs if it does not help.

Similar Threads

  1. Error opening file for writing - HM2
    By Morris2790 in forum General Support
    Replies: 1
    Last Post: 03-24-2020, 09:38 AM
  2. Bugs Bugs Bugs Bugs
    By shaddi in forum Bug Reports
    Replies: 4
    Last Post: 03-25-2012, 01:20 AM
  3. Error opening file for writing
    By 7Suarez7 in forum General Support
    Replies: 1
    Last Post: 02-18-2012, 03:25 AM
  4. Error when writing to open file
    By DonCoryon in forum Manager General
    Replies: 3
    Last Post: 05-07-2010, 03:55 PM
  5. Replies: 1
    Last Post: 04-06-2010, 12:06 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •