literate-perfunctory
Poker Software
Results 1 to 5 of 5
  1. #1
    Member
    Join Date
    Nov 2008
    Posts
    75

    Default "Sorry, could not install postgreSQL"

    Hello,

    I'm trying to install HEM2 for a friend, and received error above.

    I followed all the advice in posts #2 and post #4 in this thread:
    https://forums.holdemmanager.com/sho...d.php?t=537110

    Postgres 8.4 installed successfully after I followed post #4 exactly.
    I still get same error message when I try install HEM2.

    Do I need to use a newer version of postgres than 8.4?

    Its a brand new laptop running windows 10
    I turned off UAC.
    I uninstalled completely McAfee, and turned off windows defender firewall.

    Thanks

  2. #2
    HM2! udbrky's Avatar
    Join Date
    Jul 2008
    Posts
    18,940

    Default

    If you continue to have problems, please duplicate the issue and send us log files with a detailed description of what you were doing and what problems you were experiencing:
    - Open Windows Event Viewer's (Control Panel - System & Security - Administrative Tools or Start - Search - 'Event Viewer') - Windows Logs - Applications.
    - Check for any errors and send the information (Save All Events As...).
    - Please send your \HM2Logs folder files as well - http://hm2faq.holdemmanager.com/ques...ger+Support%3F

    When sending any files please zip them (right-click - send to - compressed folder) before attaching them to an email. If the attachment is larger than 10MB please upload them to a file hosting site like dropbox, then right-click - 'copy dropbox link' and paste the download link directly into the support ticket email. If you have any problems with dropbox try using filedropper.com
    Regards udbrky (Chris)

  3. #3
    Member
    Join Date
    Nov 2008
    Posts
    75

    Default

    I emailed the Event log.

    There is no HM2Logs folder yet on the computer, because HEM2 will not install. It's a new computer.

    I had already carefully done the following before asking for help:
    1) Removed 3rd party antivirus
    2) Disabled Windows Defender firewall
    3) Disabled UAC

  4. #4
    Member
    Join Date
    Nov 2008
    Posts
    75

    Default

    The error appears when I try to install HEM2 for the first time.

    It begins to install, unpacking all the files and after about a minute or 2, the error appears, and I have to cancel the installation.

  5. #5
    HM2! udbrky's Avatar
    Join Date
    Jul 2008
    Posts
    18,940

    Default

    Did you try using the standalone installers?

    Make sure windows is fully updated until 'No New Important Updates are Found' (this may require multiple restarts and multiple 'check for updates'), including Internet Explorer (even if you use a different web browser).

    Please note that reinstalling PostgreSQL will mean losing all your old data. If you have access to HM2 and your database was not corrupt then please follow these instructions for backing up your database as a precaution in case you cannot reconnect after reinstalling PostgreSQL.

    If you cannot access the database in HM2 then you can backup your database using this method but if your database was corrupt then the best solution is to reimport all your hands from C:/HM2archive folder or if your pokersite supports it you can request all your hands and summaries and reimport them as restoring a corrupt database will just restore all the problems you had.

    1) Uninstall PostgreSQL from the Windows Control Panel.

    2) Delete the \PostgreSQL\X.x\data folder that is left behind.

    3) Delete the sub-folder(s) in c:\users\username\appdata\roaming\HoldemManager\Da tabase (XP - c:\documents and settings\username\application data\HoldemManager\Database).

    4) run the command - start > programs > accessories > command prompt > right-click > run as administrator

    net user postgres /delete

    After you click 'Enter' for the code above also do that same for this code:

    sc delete postgresql-8.4

    and click 'Enter' again.

    5) Restart your PC

    6) Install PostgreSQL 9.3 from here.

    7) Once installed you should disable the postgresql logging as instructed here.

    If there is still an issue, we need to know the error - it is in the temp folder - bitrockinstaller.txt file. If you can't see it, turn off the windows option that is hiding that directory.
    Regards udbrky (Chris)

Similar Threads

  1. Combo Installer: "Sorry, could not install PostgreSQL"
    By Pureman in forum Manager General
    Replies: 61
    Last Post: 07-03-2013, 09:27 PM
  2. Again HM2 "sorry could not install postgresql"
    By oscillo in forum General Support
    Replies: 3
    Last Post: 02-10-2012, 12:41 PM
  3. "sorry,could not install PostgreSQL"
    By jpee in forum Manager General
    Replies: 6
    Last Post: 07-26-2011, 11:51 PM
  4. "sorry,could not install PostgreSQL"
    By yangpenger in forum Manager General
    Replies: 14
    Last Post: 05-09-2011, 07:06 PM
  5. "Sorry, could not install PostgreSQL"
    By lolerskates in forum Manager General
    Replies: 4
    Last Post: 03-22-2011, 10:01 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •