Database config "upgraded"
Results 1 to 8 of 8
  1. #1
    Junior Member
    Join Date
    Mar 2012
    Posts
    29

    Default Database config "upgraded"

    Hey! I was doing the maintenance to my database and I noticed some button below that said to change settings of the database to those that would be more compatible to my computer specification. So I clicked that in hope of getting more out of my computer. And that was a huge mistake. I got some random error saying that a certain file couldn't be found. Then after doing the maintenance again it was instantaneous which got me thinking that something is wrong. Then when I got to reports I saw that it doesnt show my rakeback value anymore, so I clicked settings -> rb and bonuses and HM froze. I restarted windows. Now I can't connect to postgres anymore... I was trying couple of things from http://hm2faq.holdemmanager.com/ques...rt+PostgreSQL+ but my situation is quite different from other guys, coz my postgres was working perfectly, but HM fucked it up :/ Please help.

  2. #2
    You're out! udbrky's Avatar
    Join Date
    Jul 2008
    Posts
    20,818

    Default

    It sounds like something was corrupted.

    Close HM2.

    Go to Control Panel - administrative tools (system & security) - Services and turn off Postgres.

    Go to c:\programfiles\postgresql\version#\data and delete the postgresql.conf, pg_hba.conf and postmaster.pid files

    This could also be programfiles(x86) or just c:\postgresql. There also may not be a folder for the version #, just the folders and files.

    Reinstall the same version from Download PostgreSQL | EnterpriseDB

    Make sure that Postgres restarts in services.

    Now try just doing the maintenance.
    Regards udbrky (Chris)

  3. #3
    Junior Member
    Join Date
    Mar 2012
    Posts
    29

    Default

    Thank you for the quick answer. I'm unable to stop the service because it seems to not even run. I tried with services.msc and with stop server (returns an error (2)). Should I proceed with the rest of the instructions anyway?

  4. #4
    HM Support Patvs's Avatar
    Join Date
    Feb 2009
    Location
    Amsterdam, the Netherlands
    Posts
    33,523

    Default

    Quote Originally Posted by MIStrZZZ View Post
    I noticed some button below that said to change settings of the database to those that would be more compatible to my computer specification.

    Was this button in HM2? Or you were doing maintenance manually in PGADMINIII, or you upgraded PostgreSQL (for example from 8.4.x--> to 8.4.22 / 9.x.x to newer version of 9.x.x) and during the install/update process it gave you the option in a Tuning Wizard to optimize your settings for performance?


    If you did the last, on some systems it will make changes to the postgresql.conf it shouldn't, resulting in being unable to connect to the database! If you experience this problem--> simply go to the PostgreSQL/8.4/data folder, undo the changes made to postgresql.conf and reboot.

    Or delete the postgresql.conf file and reinstall PostgreSQL.
    Sometimes there also will be a postgresql.bak file (with your old settings). You can then delete postgresql.conf, and rename the postgresql.bak file to postgresql.config (and reboot).
    Participate in the Beta release of the newest Hold'em Manager version: HM Cloud. Sign-up HERE.

    If you would like to leave some feedback to help us improve the quality of the solutions, and/or the support quality you received, - you can do this here

  5. #5
    Junior Member
    Join Date
    Mar 2012
    Posts
    29

    Default

    No, it was the first option - in HM2, it's the button directly below full maintenance option. It's called something like "optimize your HM2 settings to match your computer specs so it will run smoother".

    Quote Originally Posted by Patvs View Post
    Or delete the postgresql.conf file and reinstall PostgreSQL.
    Sometimes there also will be a postgresql.bak file (with your old settings). You can then delete postgresql.conf, and rename the postgresql.bak file to postgresql.config (and reboot).
    is this what I should do next?
    Last edited by MIStrZZZ; 08-06-2015 at 03:51 AM.

  6. #6
    HM Support Patvs's Avatar
    Join Date
    Feb 2009
    Location
    Amsterdam, the Netherlands
    Posts
    33,523

    Default

    Yes.

    It appears the PostgreSQL Tuning in HM2---> =the Tuning Wizard.
    HM2 has the option to restore your old PostgreSQL.conf settings, but that's not going to help you if the PostgreSQL server is no longer running and you can't access HM2.

    To do it manually:

    -Sometimes there also will be a postgresql.bak file (with your old settings). You can then delete postgresql.conf, and rename the postgresql.bak file to postgresql.config (and reboot).

    -If you don't have a backup file. You can undo the changes manually. (open postgresql.conf with Notepad, the changes can easily be spotted, you can text search all the changes the 'tuning wizard' made)

    -Or delete the postgresql.conf file and reinstall PostgreSQL.
    Participate in the Beta release of the newest Hold'em Manager version: HM Cloud. Sign-up HERE.

    If you would like to leave some feedback to help us improve the quality of the solutions, and/or the support quality you received, - you can do this here

  7. #7
    Junior Member
    Join Date
    Mar 2012
    Posts
    29

    Default

    OK, I switched the 2010 backup config file with the current one and everything is working so far... Thanks!
    Last edited by MIStrZZZ; 08-06-2015 at 06:14 AM.

  8. #8
    You're out! udbrky's Avatar
    Join Date
    Jul 2008
    Posts
    20,818

    Default

    You are very welcome. Thank you for letting us know it solved your problems. It helps us when crafting future replies to other customers with similar problems.

    Good luck at the tables. If you have any further questions or problems do not hesitate to ask us.
    Regards udbrky (Chris)

Similar Threads

  1. Upgraded to HM2. How do I delete my HM1 database?
    By kalv in forum General Support
    Replies: 1
    Last Post: 05-09-2013, 12:19 AM
  2. Replies: 3
    Last Post: 12-28-2012, 07:23 PM
  3. Replies: 2
    Last Post: 05-23-2011, 06:42 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •