PostgreSQL 8.4 size is 108 GB
Results 1 to 8 of 8
  1. #1
    Member
    Join Date
    Oct 2008
    Posts
    32

    Default PostgreSQL 8.4 size is 108 GB

    Hello,so my Postgres size is 108GB while the only DB that i have,is 4.6GB. What can be the problem and how could i solve it? Thank you!

  2. #2
    Member
    Join Date
    Oct 2008
    Posts
    32

    Default

    I followed all of this steps: http://forums.holdemmanager.com/gene...too-large.html but the size of the Postgres is still 108GB and the DB 4.6 GB

  3. #3
    HM Support Patvs's Avatar
    Join Date
    Feb 2009
    Location
    Amsterdam, the Netherlands
    Posts
    33,523

    Default

    Does it state 108 GB in Windows: Control Panel--> Programs--> for PostgreSQL, or in
    My Computer: C:/Program Files(x86)/PostgreSQL 108 GB is the size of the folder in the folder properties?

    Is there 50 GB of files in your PostgreSQL/8.4/data/pg_log folder?
    Are you using NoteCaddy?
    Participate in the Beta release of the newest Hold'em Manager version: HM Cloud. Sign-up HERE.

    If you would like to leave some feedback to help us improve the quality of the solutions, and/or the support quality you received, - you can do this here

  4. #4
    Member
    Join Date
    Oct 2008
    Posts
    32

    Default

    Its says 108GB in Control Panel----Programs. In the folder it says 4.4 GB.
    In that folder (there is no 8.4 folder) there is only one file that says this:

    2012-08-23 17:29:47 ART LOG: el sistema de bases de datos fue apagado en 2012-08-23 17:29:20 ART
    2012-08-23 17:29:47 ART FATAL: el sistema de base de datos está iniciándose
    2012-08-23 17:29:47 ART LOG: el sistema de bases de datos está listo para aceptar conexiones
    2012-08-23 17:29:47 ART LOG: lanzador de autovacuum iniciado
    2012-08-23 17:30:55 ART WARNING: pgstat wait timeout
    2012-08-23 17:32:04 ART WARNING: pgstat wait timeout
    2012-08-23 17:32:28 ART LOG: se recibió petición de apagado rápido
    2012-08-23 17:32:28 ART LOG: abortando transacciones activas
    2012-08-23 17:32:28 ART LOG: apagando lanzador de autovacuum
    2012-08-23 17:32:28 ART LOG: apagando
    2012-08-23 17:32:28 ART LOG: el sistema de bases de datos está apagado

    I let you know,that my computer is divided in 4 discs,and i have a bit of disorder in it,in case it has something to do.

    I use NC,but only very simple stats vs Hero, and i followed the steps in this thread http://forums.holdemmanager.com/gene...too-large.html

    Thank you!

  5. #5
    HM Support Patvs's Avatar
    Join Date
    Feb 2009
    Location
    Amsterdam, the Netherlands
    Posts
    33,523

    Default

    Quote Originally Posted by Robert Fripp View Post
    Its says 108GB in Control Panel----Programs

    Windows is wrong.
    It wrongly shows the database server activity in GB, not the actual size.
    Participate in the Beta release of the newest Hold'em Manager version: HM Cloud. Sign-up HERE.

    If you would like to leave some feedback to help us improve the quality of the solutions, and/or the support quality you received, - you can do this here

  6. #6
    Junior Member
    Join Date
    Jul 2009
    Posts
    3

    Default

    Even though windows may be wrong. My drive SSD is now full with half of it being the 105 GB postgresql installation. I can no longer install applications on my C drive.

  7. #7
    HM Support Patvs's Avatar
    Join Date
    Feb 2009
    Location
    Amsterdam, the Netherlands
    Posts
    33,523

    Default

    In Windows--> Control Panel--> Programs--> it shows the wrong size.

    ...but if your database actually is taking up half your diskspace, you can do two things:
    -1 in th Program Files(x86)/PostgreSQL/8.4/data/Pg_log folder delete all the files.
    -2 Are you using NoteCaddy?
    If YES, You can try resetting the Note Caddy notes. Do you have a lot of definitions?





    If NO: is NoteCaddy maybe still turned on in HM2?
    HM2: HUD Settings--> HUD Designer--> turn off show caddy notes, turn off start cady report on hud launch.
    To then delete the NoteCaddy INDEX:

    1) Please open PGAdminIII (Start - Postgres)

    2) Enter your pw (default is postgrespass)

    3) Open databases - expand DB name - expand schemas - expand public - expand Tables

    4) Delete the note_caddy_scatter and note_caddy_data

    PGAdmin info screen looks like this:
    http://i291.photobucket.com/albums/l...dbrky/null.png
    Participate in the Beta release of the newest Hold'em Manager version: HM Cloud. Sign-up HERE.

    If you would like to leave some feedback to help us improve the quality of the solutions, and/or the support quality you received, - you can do this here

  8. #8
    You're out! udbrky's Avatar
    Join Date
    Jul 2008
    Posts
    20,818

    Default

    Did you use a program like treesize free or windir stat to find what files are using how much space?
    Regards udbrky (Chris)

Similar Threads

  1. Decreasing the size of the postgresql DB
    By Gawuss in forum Manager General
    Replies: 1
    Last Post: 02-03-2014, 05:45 AM
  2. Large PostgreSQL size, not caused by log files...
    By sebasdess in forum General Support
    Replies: 1
    Last Post: 06-22-2013, 11:30 PM
  3. PostgreSQL Size
    By jl001300 in forum Manager General
    Replies: 1
    Last Post: 11-02-2011, 01:57 AM
  4. PostgreSQL 8.4 (size -> 105GB)
    By Roflpain in forum Manager General
    Replies: 3
    Last Post: 09-09-2011, 04:23 AM
  5. postgresql size
    By bacon sashimi in forum Manager General
    Replies: 2
    Last Post: 05-26-2010, 03:22 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •