Postgress won't connect
Results 1 to 6 of 6
  1. #1
    HM2 Shark Tank Member
    Join Date
    Feb 2010
    Posts
    1,657

    Default Postgress won't connect

    Worked fine for years, closed down last night and now it won't connect

    I have tried every method I could, following ALL the tips on here, including watching the video (postgres can't connect)

    UAC is off, I deleted all anti virus, re installed 8.4 yet still won't connect

    Tried through HM2 and PGAdmin all run as admin

    I did note that when I reinstalled at the end it said can't connect to server during installation

    I even changed the port to 5433 for ver 9.1

    Postgres is allowed through the firewall

    So i uninstalled both and reinstalled using the "download a trial" version

    When ran it said " could not install postgres"

    At a loss what to try next as I have ran out of ideas

    HELP PLEASE, as i support 100 guys who use HM2 am at a loss of what the problem could be

    The pic is the error when i try to connect through PGadmin

    The 2nd Pic is when trying to run through HM1

    Below is the install error output

    Output folder: C:\Program Files (x86)\PSQLINSTALL
    top level install dir -->C:
    Is admin account
    fs=NTFS
    .NET found
    Extract: TestFirewall.exe... 100%
    Extract: TestFirewall.exe.config... 100%
    Antivirus Installed: False
    test antivirus returned 0
    seclogon error status: 0
    seclogon status: 4
    firewall enabled: 1
    firewall port 5432 enabled: 1
    port 5432 already enabled
    postgresql error status: 1060
    postgresql status: 0
    starting pgsql-8.3
    postgresql error status: 1060
    postgresql status: 0
    postgresql error status: 1060
    postgresql status: 0
    starting postgresql-8.4
    postgresql error status: 1060
    postgresql status: 0
    postgres installdir: C:\Program Files (x86)\PSQLINSTALL
    ==================== running PsqlTestClient
    try userid: postgres
    try pass: postgrespass
    try pass: postgrespass
    Connection to database failed: -->could not connect to server: Connection refused (0x0000274D/10061)
    Is the server running on host "127.0.0.1" and accepting
    TCP/IP connections on port 5432?
    <--error
    1
    testclient return status: 1
    testclient return from file: 1
    ==================== finished PsqlTestClient
    granting write permission on top level postgres directory
    found dir
    try rename C:\PostgreSQL --> C:\PostgreSQL-prev-2014-24-Mar-18-27-42
    Create folder: C:\PostgreSQL-prev-2014-24-Mar-18-27-42
    Moving files: C:\PostgreSQL\*.* to C:\PostgreSQL-prev-2014-24-Mar-18-27-42\
    Remove folder: C:\PostgreSQL\
    renamed dir
    wrote testfile
    Create folder: c:\postgreSQL
    Execute: "C:\Program Files (x86)\PSQLINSTALL\postgres84.exe" --mode unattended --superpassword postgrespass --prefix c:\postgreSQL --datadir c:\postgreSQL\data
    postgres installdir: C:\Program Files (x86)\PSQLINSTALL
    ==================== running PsqlTestClient
    try userid: postgres
    try pass: postgrespass
    try pass: postgrespass
    Connection to database failed: -->server closed the connection unexpectedly
    This probably means the server terminated abnormally
    before or while processing the request.
    <--error
    1
    testclient return status: 1
    testclient return from file: 1
    ==================== finished PsqlTestClient
    Attached Images Attached Images
    Last edited by johncc; 03-27-2014 at 06:54 AM.

  2. #2
    HM2 Shark Tank Member
    Join Date
    Feb 2010
    Posts
    1,657

    Default

    Weird,,, I downloaded ver 8.3 and it works fine

  3. #3
    *** HM3! *** fozzy71's Avatar
    Join Date
    Jun 2005
    Location
    HM Support
    Posts
    32,844

    Default

    Which version were you using originally? I see you mentioned 8.4 and 9.1 at the start of your post. Our combo installer installs 8.4.20. We do not support 9.1+ so if you have 64bit windows I would recommend you try psql 9.0.

    Which Operating System, Firewall, and Anti-Virus are you using?

  4. #4
    HM2 Shark Tank Member
    Join Date
    Feb 2010
    Posts
    1,657

    Default

    I did have 8.4

    W7 Windows defender as I removed anti virus to check if that was the problem

    It's just odd that 8.3 worked straight away

    Will give ver 9.0 a go if i have problems again

  5. #5
    You're out! udbrky's Avatar
    Join Date
    Jul 2008
    Posts
    20,898

    Default

    8.3 tends to work like that. Did 9.0 work?

  6. #6
    HM2 Shark Tank Member
    Join Date
    Feb 2010
    Posts
    1,657

    Default

    forgot to try will do it tomorrow

Similar Threads

  1. Postgress cant connect
    By roquemola in forum Manager General
    Replies: 1
    Last Post: 02-07-2013, 03:47 AM
  2. cant connect to postgress
    By A.Kmicic in forum Manager General
    Replies: 11
    Last Post: 03-23-2011, 09:06 PM
  3. postgress wont connect???
    By egosbar in forum Manager General
    Replies: 1
    Last Post: 03-31-2010, 11:12 PM
  4. Postgress cant connect problems 8.4
    By fbg1919 in forum Manager General
    Replies: 4
    Last Post: 12-22-2009, 12:48 PM
  5. New User/Can't connect to Postgress
    By geurtd in forum Manager General
    Replies: 2
    Last Post: 08-11-2009, 04:40 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •