pg_hba.conf not saving changes?
Results 1 to 4 of 4
  1. #1
    Junior Member
    Join Date
    Aug 2009
    Posts
    9

    Default pg_hba.conf not saving changes?

    I'm looking to connect to my postgres db from my local network and when i add lines to the pg_hba.conf file it doesnt save it. I add the line press save and reopen the file to verify and its not there.

    I'm following these instructions:

    Change the pg_hba.conf file likewise. Choose File/Open pg_hba.conf (file can be found in PostgreSQL/8.3/data directory).

    Add a line like in the picture by double clicking in the square in the new line

    pgadmin-03.jpg

    Add a line like host/all/postgres/0.0.0.0/md5 if you want to access your database from the internet (See also additional steps for Internet access)

    Or add a line like host/all/postgres/192.168.2.3 (= Ip-adres laptop)/md5 if you only want to access your database from inside your local network with your laptop/ second computer.

    Or add a line like host/all/postgres/192.168.2.0 (= address of your local network)/md5 if your laptop is getting an IP Adres from a DHCP server within your network.

    Or add a line like host/all/192.168.2.3/trust if you do not want have anything to do with passwords.

  2. #2
    HM Support netsrak's Avatar
    Join Date
    Feb 2009
    Location
    Germany
    Posts
    25,788

    Default

    Copy the file to your desktop. Open the copied file in the editor (you need administrator rights). Save the changes. Now rename the original file as backup copy and move the changed file from the desktop to the original folder and restart the postgresql service.

  3. #3
    Junior Member
    Join Date
    Aug 2009
    Posts
    9

    Default

    Ok it looks like it doesnt get save when u manually edit the file without a port.

    When I add a port it seems to save correctly.

    Does that look right to you?

    # TYPE DATABASE USER CIDR-ADDRESS METHOD

    # IPv4 local connections:
    host all all 127.0.0.1/32 md5
    host all all 192.168.1.1/5432 md5
    # IPv6 local connections:
    host all all ::1/128 md5
    host all all 0.0.0.0 md5

  4. #4
    Tech Support Manager morny's Avatar
    Join Date
    Jul 2008
    Location
    Ireland
    Posts
    20,888

    Default

    Yeah that looks fine
    --------------------------------------------------------------------------------------------------------------------
    We welcome any feedback on any solutions we provide, this helps us to provide better quality solutions in the future.

Similar Threads

  1. Poker Heaven: Custom HUD conf. dosent work!
    By Suusk in forum Manager General
    Replies: 5
    Last Post: 11-02-2010, 01:15 PM
  2. Postgre service doesn't start after editing pg_hba.conf
    By hypertyper in forum Manager General
    Replies: 4
    Last Post: 08-31-2010, 08:49 AM
  3. Connection Error Fata no pg_hba.conf entry for host
    By hypertyper in forum Manager General
    Replies: 2
    Last Post: 08-30-2010, 05:32 AM
  4. "missing or erroneous pg_hba.conf file"
    By scratch28 in forum Manager General
    Replies: 9
    Last Post: 04-01-2010, 10:31 PM
  5. Popup conf. HUD Layout
    By AdmObscure in forum Share your HUD configurations
    Replies: 2
    Last Post: 03-02-2010, 01:29 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •