Win7 Experience Issues
Results 1 to 5 of 5
  1. #1
    Member
    Join Date
    Jun 2009
    Posts
    54

    Default Win7 Experience Issues

    Was running XP - upgraded to Win7 today. Backed up Notes, Config dir, and dB as specified in the Help files from HEM. Once Win7 was up and I had everything installed (postgres first obv), I restored the dB and this was my experience:

    1) The restore did end on an error, but as specified I did not rerun it.
    2) When I went to import HH files from Stars, they imported but every hand was an error. (BTW, I could not find an error log file in Win7)
    3) BUG 1: I finally created a new dB, and imported the hands into that. I switched back to the restored dB and then the hands imported. (This seems like a bug to me...unfortunately a time consuming one no doubt.)
    4) I tried to import my Notes, but they were apparently already there as it said 0 notes updated.
    5) BUG 2: I then (to verify they were present) tried to export them. It says it exported to the ExportedNotes.HMNotes file in the ProgramFiles/RVG/HEM dir. However, there is NO FILE THERE.
    6) I then decided to just import all my old hands into a new dB just to be safe. I selected 233 files to import, however, the hands imported and time remaining are only updating about once every few minutes instead of every second like usual.

    I'm running 1.09 Beta 42 (before and after the upgrade.)

    Hopefully this is useful.

  2. #2
    HM Support netsrak's Avatar
    Join Date
    Feb 2009
    Location
    Germany
    Posts
    25,795

    Default

    I think your problems were caused because of the new postgresql version. The older version uses coding SQL_ASCII and the new one UTF8 by default. When restoring a backup it needs to have the same coding as the original one.

    Under Vista and Windows 7 make sure UAC is disabled http://www.holdemmanager.net/faq/afm....aspx?faqid=73
    and/or holdemmanager.exe and hmhud.exe are started as administrator. Run the windows explorer and navigate to your Holdemmanager installation directory. Right click the holdemmanager.exe, dbcontrolpanel.exe and the hmhud.exe executable and select "Run as admin" from the popup menu under compatibilty.


    Please come back if you need further help.

  3. #3
    Junior Member
    Join Date
    Aug 2009
    Location
    Finland
    Posts
    4

    Default

    Disabling UAC is very dangerous. Is there a way for you to make HEM work with UAC? UAC really is the corner stone of Windows security and there is no way I'm going to disable it.

  4. #4
    Member
    Join Date
    Jun 2009
    Posts
    54

    Default

    I'm pretty sure that when I restored the dB, it used the ASCII, and not UTF. However, I still think that #5 and #6 are potential issues that are unrelated to this.

    And hopefully over the next few months, HEM will adjust to being able to run without recommending disabling UAC. Having worked for many years in the sw industry, I understand the likely issues you're dealing with and appreciate them, but it's better to fix this now for the long term IMO.

    Thanks!
    Brian

    Edit: Also note that I had a PT dB as well, and that restored fine with no errors, and worked, so again I think this is another reason it's not due to UTF as I did them both the same.

    Edit2: I just looked in Pgadmin and it was indeed restored with ASCII, not UTF...so these issues are likely very real for everyone.
    Last edited by brianwi; 11-01-2009 at 09:29 AM. Reason: updating info

  5. #5
    *** HM3! *** fozzy71's Avatar
    Join Date
    Jun 2005
    Location
    HM Support
    Posts
    32,854

    Default

    Quote Originally Posted by janne_oksanen View Post
    Disabling UAC is very dangerous. Is there a way for you to make HEM work with UAC? UAC really is the corner stone of Windows security and there is no way I'm going to disable it.
    You can leave UAC on, just set all the EXE's to run as admin.

    Under Windows 7 you must set \holdem manager\dbcontrolpanel.exe, holdemmanager.exe and hmhud.exe to be started as administrator. Run the windows explorer and navigate to your Holdemmanager installation directory. Right click the executable's and select "Run as admin" from the compatibility tab.

Similar Threads

  1. postgeresql problem with win7
    By Zilkar in forum Manager General
    Replies: 3
    Last Post: 10-15-2009, 02:59 PM
  2. HUD doesnt work on 6max (PP + Win7 x64)
    By keel in forum Manager General
    Replies: 1
    Last Post: 10-09-2009, 08:48 AM
  3. [Help] Win7 x64
    By JourneyOfMan in forum Manager General
    Replies: 2
    Last Post: 09-05-2009, 09:21 AM
  4. HEM w/ Postgres 8.4 and Win7
    By TaoJones in forum Manager General
    Replies: 1
    Last Post: 07-08-2009, 06:09 AM
  5. Vista + Win7 on one PC + Laptop
    By ImSoCute in forum Manager General
    Replies: 3
    Last Post: 03-26-2009, 01:23 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •