importing large numbers of hands, grinds to a halt
Results 1 to 8 of 8
  1. #1
    Member
    Join Date
    Nov 2008
    Posts
    32

    Default importing large numbers of hands, grinds to a halt

    I keep trying to imprt large numbers of hands. When I import small numbers I can import at like 70ish hands a second. When I do large numbers it starts at like 30-40 a second and grinds down to like 9-10 a second.

  2. #2
    Tech Support Manager morny's Avatar
    Join Date
    Jul 2008
    Location
    Ireland
    Posts
    20,889

    Default

    Try doing a defrag with this tool its very good http://www.defraggler.com/ and should increase speeds

    Turn off the postgreSQL service while your doing it Start > All Programs > PostgreSQL > Stop Service and then turn it back on when finished Start > All Programs > PostgreSQL > Start Service
    --------------------------------------------------------------------------------------------------------------------
    We welcome any feedback on any solutions we provide, this helps us to provide better quality solutions in the future.

  3. #3
    Member
    Join Date
    Nov 2008
    Posts
    32

    Default

    Quote Originally Posted by morny View Post
    Try doing a defrag with this tool its very good http://www.defraggler.com/ and should increase speeds

    Turn off the postgreSQL service while your doing it Start > All Programs > PostgreSQL > Stop Service and then turn it back on when finished Start > All Programs > PostgreSQL > Start Service
    Its a fresh install of windows 7 RC mate, doesn't need defragging. Or do you mean defrag the db?

  4. #4
    Tech Support Manager morny's Avatar
    Join Date
    Jul 2008
    Location
    Ireland
    Posts
    20,889

    Default

    It can vary alot with smaller samples, with bigger samples it takes a while to workout the time as it estimates it based on the hands it has imported so far plus as the database grows the speed will decrease. 10h/s is on the slow side but Roy said hell be revisiting tuning this so everyone sees and increase in import speeds.
    --------------------------------------------------------------------------------------------------------------------
    We welcome any feedback on any solutions we provide, this helps us to provide better quality solutions in the future.

  5. #5
    Junior Member
    Join Date
    Oct 2009
    Posts
    9

    Default

    i have the sample problem...installed windows 7 today and teh impoert is at 10 hands per second...on windows xp it has been at least 60 per second

    dunno what the probelem is

  6. #6
    *** HM3! *** fozzy71's Avatar
    Join Date
    Sep 1971
    Location
    HM Support
    Posts
    30,212

    Default

    Laptop or desktop? Laptops are typically much slower than desktops. My 3 year old XP machine imports at 40 h/s and my new Vista machine is twice that or more.

    Please update to the latest beta - http://www.holdemmanager.com/downloads/HmBetaUpdate.exe

    Under Vista and Windows 7 make sure UAC is disabled http://www.holdemmanager.net/faq/afmmain.aspx?faqid=73 or holdemmanager.exe, hmhud.exe, and dbcontrolpanel.exe are started as administrator. Run the windows explorer and navigate to your Holdemmanager installation directory. Right click the dbcontrolpanel.exe, holdemmanager.exe, and the hmhud.exe executable and select "Run as admin" from the popup menu.

  7. #7
    Junior Member
    Join Date
    Oct 2009
    Posts
    9

    Default

    Done. Its still that slow. not even 20 hands p/s. I have an E8400 duo core with 2 gig ram.

  8. #8
    *** HM3! *** fozzy71's Avatar
    Join Date
    Sep 1971
    Location
    HM Support
    Posts
    30,212

    Default

    You didnt answer if it was laptop/desktop? This wouldnt surprise me on a laptop. I cant imagine why installing w7 would make such a big difference.

    I would suggest you do the majority of the things in this thread: http://www.holdemmanager.net/forum/s...ad.php?t=11194

    Some of the most important things, imo:

    - Remove the WinnerName, WinnerCards and WinnerWon from the Hands View Column Selector
    - Turning off logging and deleting existing logs
    - Vacuum/Full/Analyze, then Reindex - http://www.holdemmanager.net/faq/afm...aspx?faqid=163
    - Defrag last and make sure you stop the postgresql service before you defrag. I personally use Smart Defrag.
    - Do a Cold Boot (Shut Down > Start) before you use HM again

    Which version of postgresql did you install?

    Try reinstalling 8.4 if you dont have it. http://forums.holdemmanager.com/showthread.php?t=20755

    and check this thread - http://forumserver.twoplustwo.com/28...mputer-362568/



    Did you turn off logging?


    Logging:

    I would suggest you turn off logging on your new SQL installation as well as these other performance improvements - Top 10: HEM performance increase tips


    To turn off logging, follow these instructions. This is the first thing I do anytime I install SQL for someone.

    - Start > My Computer > Tools > Folder Options > View > UnCheck 'Hide Extensions for known file types' > OK

    - C:\Program Files\PostgreSQL\data\postgresql.conf > Right-Click > Open With.. > NotePad > Check 'Always use this program'

    - Scroll about half way down to ~Lines 245 - 260:

    - The last line of this block of code, for the 'logging_collector', must be changed from On to Off.


    HTML Code:
    ------------------------------------------------------------------------------
    # ERROR REPORTING AND LOGGING
    #------------------------------------------------------------------------------
    
    # - Where to Log -
    
    log_destination = 'stderr'        # Valid values are combinations of
                        # stderr, csvlog, syslog and eventlog,
                        # depending on platform.  csvlog
                        # requires logging_collector to be on.
    
    # This is used when logging to stderr:
    logging_collector = off        # Enable capturing of stderr and csvlog

    File > Save; File > Close

    Start > Programs > PostgreSQL 8.3 > Reload Configuration.


    - Start > My Computer > C:\Program Files\PostgreSQL\data\pg_log, or C:\Program Files (x86)\PostgreSQL\data\pg_log, if you have 64 bit Vista. Delete all files in that folder. And it might be a good idea to empty your recycle bin at that point, or use a 3rd party utility like CCleaner to clean up all your junk/temporary files. You want to do this before you get to the vacuum and defrag process.

Similar Threads

  1. problem importing large # of hands
    By hawkeye in forum Manager General
    Replies: 4
    Last Post: 05-05-2009, 03:53 PM
  2. display hands between dates or numbers
    By Dr1Gonzo in forum Manager General
    Replies: 6
    Last Post: 03-19-2009, 09:27 AM
  3. Not importing and not showing correct hand numbers
    By Fortunata in forum Manager General
    Replies: 5
    Last Post: 10-02-2008, 01:19 PM
  4. Problem importing large files.
    By Peleus in forum Manager General
    Replies: 1
    Last Post: 07-18-2008, 11:11 AM
  5. Bug in importing large amounts a hands.
    By Yersh in forum Manager General
    Replies: 2
    Last Post: 07-17-2008, 08:18 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •