literate-perfunctory
Poker Software
Page 1 of 2 12 LastLast
Results 1 to 10 of 17
  1. #1
    Junior Member
    Join Date
    Sep 2008
    Posts
    14

    Default PostGres Installation error ( Secondary Logon Service )

    Could somebody help me get PostGres going without the default options of creating a service? My problem is that the Secondary Logon Service was stripped from my install and PostGres does not run right without it. I can get it to install by unchecking the install as service option but it still gives me the error "Secondary Logon Service unavailable..." when finishing the installation ( its trying to run under the account I am logged in as ). I cannot recreate this service, I have tried rebuilding the entries in registry and using the create service command. The service just never starts.

    I run the Start command for PostGres after the installation then load HEM and it says it cannot connect to the DB. I know it can run without this service as Pokertracker 3 installs and runs fine when using their PostGres installer that is bundled with PT3.

    This machine is running Windows XP sp2 nd HEM Pro whatever the latest build is.

    Anyone with experience using PostGres, I would appreciate your help.

  2. #2
    Junior Member
    Join Date
    Sep 2008
    Posts
    14

    Default

    I got this working by installing PokerTracker3 with PostGres then using HEM to create a new database.

    For anyone with the same problem see below

    Install HEM
    Install PT3 with PostGres using all default options.
    Open HEM and connect to PostGres using username and password of your choosing
    Let HEM configure PostGres to use your username and password
    Create a new database
    Set as default
    Start HEM
    Uninstall PT3
    Do not Uninstall PostGres installed by PT3


    its dirty but it should work for anyone having the same problem.

  3. #3
    Junior Member
    Join Date
    Aug 2009
    Posts
    6

    Default

    Had the same problem, great solution, problem solved

  4. #4
    Junior Member
    Join Date
    Apr 2009
    Posts
    7

    Default

    Didn't work for me, once I try connecting with HEM it won't accept any password.

    I'm considering getting a software that actually fucking works consistently, if there is such a thing. Switched from PT2 to HEM, payed the max amount for both and frankly, this software is really fucking high maintenance and so full of problems I'm considering playing sites that don't allow trackers.

  5. #5
    Graphics Guru fozzy71's Avatar
    Join Date
    Sep 1971
    Location
    HM Support
    Posts
    27,928

    Default

    Quote Originally Posted by Stoneburg View Post
    Didn't work for me, once I try connecting with HEM it won't accept any password.

    I'm considering getting a software that actually fucking works consistently, if there is such a thing. Switched from PT2 to HEM, payed the max amount for both and frankly, this software is really fucking high maintenance and so full of problems I'm considering playing sites that don't allow trackers.
    What is the problem specifically? This thread is 2 months old.

    If you need to install sql, to a clean db:

    Please update to the latest beta - http://www.holdemmanager.com/downloads/HmBetaUpdate.exe

    Under Vista and Windows 7 make sure UAC is disabled http://www.holdemmanager.net/faq/afmmain.aspx?faqid=73 or else you must set \holdem manager\dbcontrolpanel.exe, holdemmanager.exe and hmhud.exe are started as administrator. Run the windows explorer and navigate to your Holdemmanager installation directory. Right click the executables and select "Run as admin" from the popup menu. Windows 7 you MUST set all the executables to always run as admin.

    Turn off Windows Firewall for installing HM and PostgreSQL. Once you get those installed you can add exceptions to the firewall. If you have a 3rd party firewall, uninstall it completely before installing HM/SQL - http://www.holdemmanager.net/faq/afm...aspx?faqid=171

    For reinstalling SQL to a new/empty DB, please follow these steps:

    1) Uninstall PostgreSQL from the Windows Control Panel.
    2) manually delete or rename the Program Files\Postgresql folders
    3) run the command - start > programs > accessories > command prompt > right-click > run as administrator
    PHP Code:
    net user postgres /delete 
    4) reboot.
    5) Install PostgreSQL 8.4, with your firewall uninstalled or turned off if windows firewall - http://www.enterprisedb.com/products...oad.do#windows

  6. #6
    Junior Member
    Join Date
    Apr 2009
    Posts
    7

    Default

    Took close to two hours but after following your instructions I finally got it to work and the importing seems to be working as well. Cheers.

  7. #7
    Junior Member
    Join Date
    Nov 2009
    Posts
    1

    Default

    Hi guys.

    this is probably an old thread but I googled my problem and found it.

    I can't install sql. Windows 7 says I need to have "Secondary Logon Service" running.

    I've tried what fozzy wrote but I still get the same error. I'm not able to run the "postgresql-8.3" file as an administator (dunno why?). I've set the three files in my Holdem Manager folder to be run as administrator though. I've tried to run the "postgresql-8.3" with "run as" and then running as my administrator (even though I don't think this should be neccesary 'cause I'm already logged in from my administrator account) but I can't for some reason.

    Any help would be much appreciated as I'm getting pretty desperate. I've spend several hours on this and I'm hating life, Windows and HEM right now.

  8. #8
    Graphics Guru fozzy71's Avatar
    Join Date
    Sep 1971
    Location
    HM Support
    Posts
    27,928

    Default

    Install this version of postgresql - http://www.holdemmanager.com/downloads/pginstaller.exe

    If you get an error that the user account already exists, follow these instructions - http://forums.holdemmanager.com/showthread.php?t=20755


    Once you actually get postgresql installed the instructions for the secondary logon service should work.

  9. #9
    Junior Member
    Join Date
    Nov 2009
    Posts
    1

    Default

    hey i have the same problem, tried with the last solution from fozzy, but this is what I got after like 80% of the process passed:

  10. #10
    Graphics Guru fozzy71's Avatar
    Join Date
    Sep 1971
    Location
    HM Support
    Posts
    27,928

    Default

    Quote Originally Posted by legendus88 View Post
    hey i have the same problem, tried with the last solution from fozzy, but this is what I got after like 80% of the process passed:
    Please email me at fozzy@holdemmanager.net, with a link to this thread, and your forum name, so we can schedule a Teamviewer session. Download the Teamviewer Quick Support Module - http://www.holdemmanager.com/downloads/TeamViewerQS.exe. Please let me know what time zone you are in and what time/days are convenient for you.

    I would like to run a test client on your PC to see why our installer is failing, and what I can do to get you up and running.

Similar Threads

  1. Error message after installation
    By Floeee in forum Manager General
    Replies: 4
    Last Post: 09-19-2008, 06:35 AM
  2. SQL service wont start on EITHER of my laptops
    By originaL in forum Manager General
    Replies: 2
    Last Post: 09-08-2008, 11:59 AM
  3. Error message during installation of PostgreSQL
    By mrsAA in forum Manager General
    Replies: 3
    Last Post: 08-12-2008, 10:44 AM
  4. Installation Questions
    By blizzard in forum Manager General
    Replies: 6
    Last Post: 08-01-2008, 09:03 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •