View Full Version : PostgreSQL error

07-10-2008, 09:48 AM
I keep getting this error so I can't use HM:


I have Windows XP. When I go to "Control Panel\Administrative Tools\Services" it shows me Postgre is "Automatic" but the status is blank. When I try to start it manually I get this error:


I have Kaspersky turned off and also the firewall. I have no ideea what to do, but please hurry, I really need HM to work.

Thank You in advance

07-10-2008, 12:46 PM

Can you close down all programs that might be using postgreSQL like EV Grah, PT2 etc and then reboot your computer. Disable/Exit/Close your firewall and any antivirus programs. Also if youve a 3rd part firewall like zonealarm make sure your built in firewall isnt running aswell by going to Control Panel > Windows Firewall and in the general TAB switch it to off.

Then after the computer reboots go to C:\Program Files\PostgreSQL\8.2\data and delete the postmaster.pid file then restart holdem manager. If you get the error again repeat the step above to restart the postgres service.

Let me know how that goes

07-11-2008, 10:51 AM
Hello, I have had a similar problem.

I closed the Windows Firewall and then restarted. I don't have a postmaster.pid file but I do have 'postmaster.opts' file. I deleted that and tried to connect but I still got the same error message.

07-11-2008, 10:59 AM
kwan i need to know your exact errors, can you write them down or send me a screenshot. Also its probably easier to start a new thread for your problem, in the meantime please try this:

07-11-2008, 11:17 AM

This is the error I get when I load HEM


It then leads to this box after I click OK


There is a password there, I just erased it. I click connect and it says that "A connection could not be made to PostregSQRL." I followed the FAQ and PostregSQRL is starting and there is no firewall.

07-11-2008, 11:48 AM
You need to enter the correct password there. When you were setting up
PostgreSQL it would have asked you to choose a username and password, you
should enter this password and then press connect otherwise youll get that
error. Can you remember the password?


07-11-2008, 11:52 AM
I do know the password and I entered it correctly but still get the same error.