View Full Version : Connection establishment timeout

11-09-2008, 09:29 AM
I have format and reinstall vista on my laptop.
Now I have two pbs with HM.
First, my serial is recognized and I register without pbs but I can't activate. I always have the error "no more activations allowed. You must first deactivate the software from the original machine before attempting to activate again."
But I've just sent a mail to the support with more details.

The most important is my second problem.
I can't create a new database. Everytime I try, I have this message :
The following error occured when trying to initialize the Holdem Manager database : Connection establishment timeout. Increase Timeout value in connectionstring.

11-09-2008, 10:22 AM
Hi update to the newest version of PostgreSQL http://www.holdemmanager.net/faq/afmviewfaq.aspx?faqid=72 and the newest version of HM http://www.holdemmanager.com/downloads/HmUpdate1.06.04beta.exe and then reboot

If Roy hasnt got back to you yet about activation please see this thread: http://www.holdemmanager.net/faq/afmviewfaq.aspx?faqid=159

11-09-2008, 10:51 AM
I already installed the last version of HM.
I have the 8.3 version of postgress, I'm installing now the last version ty for the link.
Also, Vista is installing a ton of updates. Maybe it'll work after all those updates.
I'll give you news.

11-09-2008, 12:43 PM
Morny, nothing changed.
I updated Vista, HM and Postgress to the last versions/updates.
I still have the error while HM try to create a new database.
For the activation, I've done all the steps in the FAQ but it still doesn't work.

News : I've installed PT3 and he succeed to create a database. Also, I've not the vista firewall and no antivirus/firewall that could prevent the connection.

11-09-2008, 06:46 PM
Hi, this is almost always due to a firewall / anti virus / spyware type program blocking Hm from accessing the database.


11-09-2008, 06:57 PM
Yes, I already read what you said on 2+2.
But I've just formated and reinstal Vista. There is no software. Just Vista, HM, Postgres, PT3, my poker room.
I've disabled the Vista firewall. I've disable the Vista user access thing.
I'm searching in "windows defender" if I can unlock something.

11-09-2008, 08:58 PM
This thread may help as it details how and what to give exceptions in Defender and windows firewall, id still add the firewall ones to the exceptions even though it is set to off because ive seen cases where they still manage to block even though there turned off. Just follow the exceptions part of this FAQ http://www.holdemmanager.net/faq/?f=171

11-10-2008, 06:24 AM
ty morny
I've done everything that's written in this faq post.
I have disable windows defender, added the port for postgres, added the authorized software for hm and postgres.
I have reinstalled postgres (the last version).

Nothing solved the problem.

I'm installing the "Service pack 1" for vista. Maybe it will help, I don't know what I can do.
Weird that it works with PT3 (creating a database). Doesn't it mean that it's a pb w/ HM ?

11-10-2008, 02:05 PM
It just might mean that something like a firewall or antivirus etc is blocking HM and not blocking PT, can you email me and ill do a teamviwer session to have a look at this problem morny@holdemmanager.net

11-29-2008, 11:59 AM
I reformated again, reinstalled Vista and SP1. Made everything you said :
- last version of HM and Postgres
- Completly disabled Defender and the firewall
- Add all the exceptions for postgres and hm to the firewall and defender even if they are disables
- Disabled the UAC
- Check if the service was running (it was) and restarted it without success.

Maybe something relevant (I don't know) but when the SP1 was not installed, the postgres installation was aborted by an error something like "Failed to run initdb: 1".

I know Roy says everytime that it's a problem with a firewall/antivirus but my installation is clean. I've only Vista, no others firewall/antivirus and I've fully disabled the firewall and defender and add the exceptions.
It's something else.

And I know PT3 worked while HM made this mistake so maybe you can try to think about searching something in your software because I really tried everything.

11-29-2008, 08:50 PM
If you email me ill do a TV session to have a look