View Full Version : Postgresql - connection refused.

10-15-2012, 08:24 PM
Hi everyone, im not sure if I'm posting in the wrong forum, if that's case im sorry.

I just bought myself a new computer to grind on, as the old is pretty fucked up atm. Here is link to my computer:
Samsung Series 9 2012 (15″) Review Ultrabook News and the Ultrabook Database (http://ultrabooknews.com/2012/06/23/samsung-series-9-2012-15-review/)

When I'm trying to install, everything goes smoothly until the end, thats where i get problem when it comes to installing postgresql. This is what i get as error:


I have Win7 and this what ive tried so far:

1) PC name must be in english - my computer name is "Mikal"
2) My windows name is the same, i have also tried to reboot my computer. Have also tried to install running as administrator.
3) Secondary logon i could chose between automatic delayed and automatic, i took automatic.
4) UAC is off.
5) Have firewall disabled

So whats wrong?


10-16-2012, 05:02 AM
Did you start the secondary logon service after changing the start type or was it already running?

I suggest you download the latest postgresql 8.4 installer from PostgreSQL: The world's most advanced open source database (http://www.postgresql.org) and try to install this one. At least it should give you a more detailled error message.

10-16-2012, 06:20 AM
Yeah, i've done that several of times allready. Can't get it installed at all, if i try with your combo installer og if i install postgresql alone i dont work.

10-16-2012, 06:27 AM
Tried to install it again.


What now? Somehow the program still got installed and it made a folder and put some files into it.

10-16-2012, 12:28 PM
Please try this:
- uninstall Postgres from Control panel (but do not delete windows user)
- download latest 8.4 from PostgreSQL: The world's most advanced open source database (http://www.postgresql.org)
- do right-click - run as admin on downloaded instalelr and install postgres manually - but NOT in default folder
(set C:\Postgresql as install.folder)

If no success - uninstall it again, but do NOT delete that folder
do right-click on it - properties - security - set full access for user "everyone"
and try installation again

If even this will not install - uninstall postgres, then
open CMD (as admin) and execute following command there
netsh winsock reset
you should receive message about successful execution
reboot PC and try again