View Full Version : database wont start

martin dtc
05-08-2012, 03:25 PM
This problem is pretty urgent because I have a coaching session scheduled tonight, and it will involve HEM..

for some reason this happens:

whenever I try to start HEM a popup sign comes up which i added as updateDBstructure

it is inactive for a while and then this error occured, which i also added to this message

how can I start my DB?

there is not enough time for an export/import, and even if there were I will lose my notes and bonus-settings..

what should I do?6711167121

martin dtc
05-08-2012, 03:26 PM
in addition:

I have latest HEM (update from 4 may i believe) although it didnt work on the official 1.12.09 either..

question: If I totally delete HEM and reinstall, will I be able to maintain the same Database (including notes, rakebackbonus-file, hud configuration, everything)

if my db is corrupted for any reason and unusable, will I be able to get into the configuration somehow and load the notes, rakebackbonus-file, hud configuration*, etc.) ?

* less important, because when Im creating a new DB this will stay the same, notes & rakebackbonus are lost though

PS: I have created a new DB which seems to working perfectly fine

How do I increase CommandTimeOut Value ? from the second screenshot (the error) it seems like this would be helpfull

I hope you will answer all my questions on short notice since its very important to me..

05-08-2012, 09:37 PM
You can downgrade to 1.12.09: then export your notes/rakebackbonus-file.

In 1.12.10 you'll have to reimport your hands first (then import the notes and rakebackbonus file) into the new database you created.

You can increase the TimeOut value by editing the postgresql.config file (but it probably won't result in being able to connect to the old database)

martin dtc
05-09-2012, 06:44 AM
if I downgrade to 1.12.09 how will I be able to export my notes/rakebackbonus-file if I cant enter my DB ?

Should I delete my current HEM first or just overwrite it?

martin dtc
05-09-2012, 07:21 AM
furthermore, i reimported all the hands into a new DB, downgraded to 1.12.09 and now it seems to be working fine although i am missing all my notes & my rakebackbonus-file (too bad i never exported them)..

the only thing im after right now is:
How can I retrieve the notes and rakebackbonus-file from my DB that wont start?

What can I do to enter that DB only to export my notes-file and rakebackbonus-file?

every hand i import is counted as an import error, no hands are actually imported

would support please help

05-09-2012, 09:38 AM
Sounds like your database is damaged again or something is wrong with your windows regional settings.
Please schedule a remote support session with our support. Email support@holdemmanager.com, with a link to this thread and your forum name, so we can setup a Teamviewer (http://www.holdemmanager.com/teamviewer) session.

martin dtc
05-09-2012, 10:13 AM
ive emailed them and am waiting for their response

in the meantime, what things can I try to do to fix this issue?
at least try to contribute something

05-09-2012, 11:19 PM
Assume the old database is corrupt, and start with reimporting all your handhistories into a new database.

martin dtc
05-11-2012, 11:10 AM
I had a teamviewer sessions, where pretty much all that was said was that it was due to my antivirus AVG (although AVG & HEM succesfully cooperated on my PC for >2 years)...
But I tried it anyway,
I deleted AVG leaving my without antivirus for a few minutes.. But HEM showed the exact same problems as before
when importing hands I get a big load of import errors which seem unnecessary
whats my next step?
PS: I reinstalled AVG since I need an antivirus and I always was satisfied with AVG

05-11-2012, 09:54 PM
Which PostgreSQL version were you using?
Install a different version to a different port (for example 8.2 to port 5433) and use that instead.

AVG shouldn't cause any issues.

martin dtc
05-12-2012, 11:41 AM
first of all, thats weird, since the guy I had teamviewer with said it was due all to AVG.
he wanted that he would delete AVG on PC. I didnt trust the whole situation and glad I didnt let him do that. Still, this seems like something u guys should look into.

second, i have postgres 8.4, but i have no knowledge on the area of postgres.
could u please eloborate on how I should do that.. and if I need to delete the old postgres??
I also have an external hard drive from which I run the postgres.
I have it installed on my C drive but a lot of DB postgres stuff in on my external hard drive, since I live in 2 cities and that way I can use 1 DB..
I have no idea how I did this back then, I got some help from this forum probably...

05-13-2012, 12:11 AM
Install: http://ftp.postgresql.org/pub/binary/v8.2.22/win32/postgresql-8.2.22-1.zip (SQL 8.2)
to port 5433 (to your C drive).