View Full Version : windows update fucked up connection to postgres

04-10-2012, 10:15 PM

When I came home today I noticed that my pc had done some updates.
When I tried opening HEM it said that it could not make connection to postgresql.

- I tried rebooting
- I tried stop/starting the service (doesnt work, it keeps stating "starting")
- Windows firewall and windows defender are both disabled, AND i did all the steps to allow all the needed processes
- I run everything as an administrator
- I dont have the \postgresql\8.x\data\postmaster.pid file
- UAC is off

I dont want to reinstall and reimport everything AGAIN, so please help me out

04-10-2012, 10:21 PM
oh and btw, I get this message after a few mins when I rebooted : "a script on this page is causing your web browser to run slowly." and only after that my skype etc launches


I dont get this when I dont let the postgres-service start automatically, I set it to manual and rebooted, so it is certainly a postgres issue

04-10-2012, 10:32 PM
these are the installed updates


and to be thorough 61281

04-11-2012, 12:52 AM
Try manually updating PostgreSQL by installing 8.4.11 from PostgreSQL: Welcome (http://www.postgresql.org).


04-11-2012, 05:39 AM
tried installing it but doesnt make a difference, still same problem
Do i first have to uninstall previous version? and will i lose any data doing this

04-11-2012, 05:44 AM
If you have any idea which windows update is causing this I might be able to uninstall it

04-11-2012, 06:13 AM
If you uninstall postgresql the data are still saved on your HDD (the postgresq\8.x\data folder).
If you then reinstall the same postgresql please follow this FAQ to keep your data:

04-11-2012, 10:17 AM
uninstalling and updating to 8.4.11 -> still same problems........

04-11-2012, 10:35 AM
deleted all the installed windows-updates, still nothing... SIGHHHH

04-11-2012, 11:40 AM
maybe this can help, I'll insert a picture of all the processes that are started when I startup my computer


as I stated before, disabling windows defender doenst help

04-11-2012, 12:23 PM
can i please talk to someone on skype or something who can check my settings with teamviewer? getting really frustrated after 3 days of not being able to work

04-11-2012, 09:05 PM
I just tried to install postgres 8.3 in another directory, I was able to start this service. Not that it is of any use but maybe it's usefull information

04-12-2012, 04:10 AM
Use SQL 8.2 or 8.3 instead. And reimport your hands.