View Full Version : Ongame Import - duplicates

11-11-2009, 02:13 PM
Hello, how can I configure HM / Ongame in order to prevent HM of importing the complete hand history (all the duplicates) each time I start auto import? The txt file in the P5 folder is getting bigger and bigger but is not beeing moved to the archiv folder...


11-11-2009, 02:36 PM
Change the Import From Subfolders option to NO, in the auto-import settings for your skin.

Delete/move the handhistory file to your archive manually, reboot your computer and try again.

11-20-2009, 02:08 AM
I have a very similar problem. Day 1: I play a few sessions (Ongame/Betsafe). Pokersoftware makes a file in Betsafes handhistory folder. Import works fine.

Day 2: I start HEM and start auto import. First its importing day 1 hands from Betsafes handhistory folder, because handhistory file is still there. These hands are duplicate hands. After HEM done this, handhistory file from poker rooms handhistory folder is gone.

I wonder why handhistory file stays in Betsafes handhistory folder to next day and then when I start HEM duplicate imports happen and handhistory file is moved to archive.

Im using newest version of HEM.

11-20-2009, 05:28 AM
Try reducing the Options > Miscellaneous Options > Change Archive Duration to 5 minutes instead of 15. At the end of sessions try to close your poker client before you stop the auto import or close HM. When you start your sessions, start HM and Auto Import before you open the poker client. That should allow for HM to archive it sooner. The poker clients sometimes stop HM from archiving the file when they are open.

11-26-2009, 05:51 AM
Import works better and faster now. Thanks for advice. I did like you suggested.

Still after day1 sessions HM leaves handhistory.log file in Betsafes handhistory folder. In day2 if I start HM import before opening Betsafes software HM archives day1 handhistories very quickly. But if I open Betsafes software before starting auto import, importing/archiving takes a long time depending how much I played day before day2.

11-26-2009, 07:43 AM
Thats because Betsafe "locks" the file.

So you need to start the auto-import before opening Betsafe.