View Full Version : HEM does'nt import all hands

10-16-2011, 04:53 PM
HEM only import every 6th hand or so :(
I've tried updating
I've tried creating new database
I tried a lot with no luck

I'm playing scandic and redkings on ongame

please help!!!

10-17-2011, 03:19 AM
Please update to the latest version 1.12.04

Which Operating System, Firewall, and Anti-Virus are you using?
Add exceptions to the windows firewall for holdemmanager.exe, hmhud.exe, hmimport.exe and dbcontrolpanel.exe, even if the firewall is turned off. If you have a 3rd party firewall, do the equivalent or uninstall it temporarily.
Make sure your video card drivers and windows auto updates are fully updated. Make sure you have Microsoft .NET Framework 3.5 SP1 (or later for w7) installed.

10-17-2011, 07:59 AM
still the same. 11 hands imported of 80 hands :(

10-17-2011, 09:16 AM
Please try with a new database

10-17-2011, 05:45 PM
Problem solved!

But what with all of my other hands from the old databases?

10-17-2011, 11:01 PM
Run a import from folder on your archive folder, reimporting all your old hands into the new database.

10-24-2011, 05:54 PM
Hey mate.

I created a new database, and played for 5-6 days without trouble. Today I've imported all the hands from the C:/HMarchive folder, but now we're back to the old problem - HEM does'nt import 90 % of the hands.

Could there be a bug in the archive folder?


10-25-2011, 12:07 AM
Most likely a hand -after being imported- corrupts the database.
This hand is not detected as a īmport error / incomplete hand, but actually is imported and then corrupts the database. (usually because the date or the handnumber is missing)

The only solution for you would be to import MONTH FOR MONTH.
When you find the month that corrupts the database, import DAY BY DAY.
Then reimport everything into a new database, except the handhistory file that corrupts it.

10-27-2011, 02:33 PM
So I created 3 new databases.
- a 2009 database
- a 2010 database
- a 2011 database.

All from the folders "2009"/2010/2011-folders in the HMarchive-folder.
None of the databases are corrupted, they alle work properly, as individuals.

When I import the all three databases in a new database, it all messes up again.


10-28-2011, 12:55 AM
Which Operating System (64 bit?), Firewall, and Anti-Virus are you using?

Which PostgreSQL version are you using?

10-28-2011, 01:50 PM
OS is Windows 7 Home Premium 64-bit
McAffee Personal Firewall 12.0
Anti-virus is McAffee Security Center 11.0

Both legid versions

PostgreSQL 8.4

Best Regards

10-29-2011, 12:57 AM
Turn off/uninstall the McAfee Firewall.

Install PostgreSQL 9.1 to port 5433 and connect to that instead, and reimport the hands.

For W7 and Vista you must set \holdem manager\dbcontrolpanel.exe, holdemmanager.exe and hmhud.exe are started as administrator. Run the windows explorer and navigate to your Holdemmanager installation directory. Right click the executables and select properties... then select "Run as admin"from the compatibility tab. If you have Vista and the checkboxes are greyed out and you can't select it, please turn UAC on, reboot, and then set the files to run as administrator.

Add exceptions to the windows firewall for those files, even if the firewall is turned off. If you have a 3rd party firewall, do the equivalent or uninstall it temporarily