PDA

View Full Version : DB Showing c80% of hands



xPeru
10-02-2011, 12:14 PM
On Pokerstars.

I'm using 1.12.03b. Will upgrade now to 04.

The database is only showing about 80% of my hands. The 20% missing seem to be randomly selected. The filter is cleared. The HUD is showing all hands, and when I hover over the icon it correctly shows my winnings.

I have created a new database (3 times) but the problem continues.

When I manually import from the HEM history folder, the missing hands remain missing. Ditto if I try to do the same from the pokerstars hand history folder. Where are they?!

Is this a postgress problem?

xPeru
10-02-2011, 11:06 PM
Advice would be much appreciated ... this is driving me crazy, because my work schedule relies on playing x hands a day, so at the moment, I'm all screwed up.

Filter is clear
Hem is updated
New DB has been created
Obv HEM & HUD are picking up hands, so the HH directories are correct and being read.

Still 15-20% of hands short!

Patvs
10-03-2011, 12:20 AM
clear filters (even though it appears no filters are selected!)

Also try setting the date filter to ALL HANDS (instead of using a "TODAY" filter)

Which PostgreSQL version are you using?
set the date formatting of your computer to M/d/yyyy (and not to European default d/M/yyyy) with regional settings English (United States)


What type of tables do you play? Example: you play Omaha cashgames (and the 5Card Omaha hands -which HoldemManager doesn't support- are all missing?)

xPeru
10-03-2011, 02:35 PM
First session in for today, and no change.

xPeru
10-03-2011, 02:36 PM
Postgres is 8.3, all other changes made. I play 6 max cash NLHE

pampaseba
10-03-2011, 03:25 PM
I have the same problem.
In graphs, appears less hands than played
In reports, appears less hands than played, but a bit more hands
In table manager, appears the exact number of hands played.

Sarek
10-04-2011, 05:01 AM
As suggested earlier,
clear filters (even though it appears no filters are selected!)
Also try setting the date filter to ALL HANDS (instead of using a "TODAY" filter)

The other thing is: meke sure these hands ARE in HH file.
Because if you closed table too fast when lose hand, room possibly did not had enough time to write them in file.

xPeru
10-04-2011, 05:13 AM
Sarek,

In a standard 1200 hand session, about 200 hands are not getting recorded, so it's not really possible that it's missing hands that happen as tables are closing. I lost ~$200 today, but HEM has me up $23 with an EV of plus $168 - it just doesn't make sense.

Patvs
10-04-2011, 06:58 AM
"In a standard 1200 hand session, about 200 hands are not getting recorded"

When you reimport the hands into a new database, what happens exactly?
Do 1200 hands import, but 200 just don't show up in HoldemManager?
Do 1000 import and 200 import as errors?

Which Operating System, Firewall, and Anti-Virus are you using?

For W7 and Vista you must set \holdem manager\dbcontrolpanel.exe, holdemmanager.exe and hmhud.exe are started as administrator. Run the windows explorer and navigate to your Holdemmanager installation directory. Right click the executables and select properties... then select "Run as admin" from the compatibility tab.

Add exceptions to the windows firewall for holdemmanager.exe and hmhud.exe, even if the firewall is turned off. If you have a 3rd party firewall, do the equivalent or uninstall it temporarily.

Make sure your video card drivers and windows auto updates are fully updated. Make sure you have Microsoft .NET Framework 3.5 SP1 (or later for w7) installed.

Turn off User Account Control: How to Disable and Turn Off UAC in Windows 7 My Digital Life (http://www.mydigitallife.info/2008/12/30/how-to-disable-and-turn-off-uac-in-windows-7/)


If that doesn't resolve it:
Install PostgreSQL 8.4.x (or 9.1.x) to port 5433
and connect to that instead (and reimport the hands into a new database again)

pampaseba
10-04-2011, 03:43 PM
I have not close the tables, I sit out for 5 mins before close them.
I play 1000 hands (table manager correctly indicated 1000 hands), but in reports, only appears 900 hands.
I dont know what is happening.
I dont know what to do, please help me.

pampaseba
10-04-2011, 03:44 PM
I have windows XP, postrgreSQL 8.4

Patvs
10-04-2011, 04:47 PM
When you reimport the hands into a new database, what does the import tab state?
Do 1000 hands import, but 100 just don't show up in HoldemManager?
Do 900 import and 100 import as errors?

Add exceptions to the windows firewall for holdemmanager.exe and hmhud.exe, even if the firewall is turned off. If you have a 3rd party firewall, do the equivalent or uninstall it temporarily.


set the date formatting of your computer to M/d/yyyy (and not to European default d/M/yyyy) with regional settings English (United States)

clear filters (even though it appears no filters are selected)

Sarek
10-04-2011, 04:48 PM
Filter > Clear and then Filter > Use for all.
Also try enabling the Options > Settings... > Miscellaneous > [x] Auto apply filter changes to all tabs

If you still cant see the new data, your DB may be damaged.

xPeru
10-04-2011, 08:58 PM
When you reimport the hands into a new database, what does the import tab state?
Do 1000 hands import, but 100 just don't show up in HoldemManager?
Do 900 import and 100 import as errors?

Add exceptions to the windows firewall for holdemmanager.exe and hmhud.exe, even if the firewall is turned off. If you have a 3rd party firewall, do the equivalent or uninstall it temporarily.


set the date formatting of your computer to M/d/yyyy (and not to European default d/M/yyyy) with regional settings English (United States)

clear filters (even though it appears no filters are selected)

All recommended actions taken, bar upgrading postgresql.

I am using Windows XP, I am not using a firewall. I use Avira antivirus.

Maybe these three pictures will help. After making all the changes recommended, including updating windows, I played a short session: Screenshot of session report, notice the minimised icon record of the same session.

http://i307.photobucket.com/albums/nn288/xperupics/HEMold.jpg

Then I created a new db and imported all the files from today Oct 4 in the HEM archive - resulting in this screen shot

http://i307.photobucket.com/albums/nn288/xperupics/Hemimportarchive.jpg

Then I imported from the Pokerstars HH archive to get any HH that HEM hadn't processed - and that got me the whole session correctly reported

http://i307.photobucket.com/albums/nn288/xperupics/hemimportstarsarchive.jpg

I will need to play another session to know whther the new db will import correctly, I will report later - sadly tomorrow!

xPeru
10-05-2011, 06:41 PM
All is now working correctly. Many thanks for the support. I'm not certain which change fixed things, but it may well have been that my db corrupted 3 times, and that whatever was causing this was fixed with the Windows update. Back to grinding, thanks again.