PDA

View Full Version : cant install PostgreSQL on windows 7 (64bit)



Nitrip
09-26-2011, 12:58 PM
hello,

the combo installer doesnt work and any other installers also. I just cant figure out whats wrong. Had always XP before.

Thanks for help

Sarek
09-26-2011, 04:13 PM
If you have Win7 (or Vista), consider the following:
1) PC name must be in English and "in one word" - requires reboot after changing.
2) The same for Windows user name. If not - create new Win user with EN name and reboot PC for this user when install Postgres. And he must have admin rights. After installation you can kill this new user - his mission is completed.
3) Secondary logon service must be set to "Autostart".
This is a standard windows service which is available on every windows computer. In the latest versions it is not started automatically. You need to start it via control panel > administrative tools > services.
4) UAC = OFF ( How to Disable and Turn Off UAC in Windows 7 My Digital Life (http://www.mydigitallife.info/2008/12/30/how-to-disable-and-turn-off-uac-in-windows-7/) )
5) Disable firewall and antivirus when installing Postgres and HM. Or uninstall them at all.
6) All installations must run "as admin" (by right-click on file). And do them as first thing after PC reboot.
7) If you want to change install path for Postgres (or to set non-default folder for database cluster) - download "standalone" installation file from Download PostgreSQL | EnterpriseDB (http://www.enterprisedb.com/products-services-training/pgdownload#windows)
8) If your Windows is not in English - you have to install Postgres not in default folder in Program_Files. Create new (example: c:\postgresql) first and select it when install.
9) Install Postgres and HM separarelly, one after one. As admin. If HM (when runs for the 1st time) says "no database" - simply create it via DBControlpanel.
10) If Postgres install fails - after uninstalling don't forget to kill windows user named "postgres":
Go to Start > Programs > Accessories > Command Prompt > Right-Click > Run As Administrator
In the window that appears please type the following and press enter:
net user postgres /del
exactly as shown. You should get a confirmation if it was successful.
11) Run all pokerclients "as admin" too.

FlyGon
06-05-2012, 05:31 PM
1) "PC"
2) "Admin"
3) Secondary logon service set to "autostart"
4) UAC set to "off"
5) winndows firewall disabled
6) runed as admin by right-click
7) Version 8.4.12 for WIN (Download PostgreSQL | EnterpriseDB (http://www.enterprisedb.com/products-services-training/pgdownload#windows))
8) c:\postgresql
9) separarelly (first postgresql)

and still error during postgres instalation:
"Problem running post-install step. Installation may not complete correctly
Error reading file c:/postgresql/data/postgresql.conf"

Thanks for help

netsrak
06-06-2012, 04:55 AM
Please try this version of postgresql: http://ftp.postgresql.org/pub/binary/v8.2.23/win32/postgresql-8.2.23-1.zip
You need to unzip the file completely to a temporary folder and start the installation from there.