View Full Version : postgres doesnt work (on vm)

08-27-2011, 06:28 AM
hi, just installad parallels on my mac and something wnet wrong installing postgre database. how to start troubleshooting?


08-27-2011, 06:01 PM
its not the local host
try to use instead

08-27-2011, 09:58 PM
same error message

08-28-2011, 06:34 AM
You need to find out which ip adress your vm uses and how to contact it.
On which installation is postgresql installed? Can you "ping" the database server PC?

08-28-2011, 07:52 AM
hi. i dont know how to find the ip address and i dont know what ping means, sry. the vm is installed on a seperate partition if thats of any importance

08-28-2011, 07:54 AM
we can do a teamviewer session if you have the time. this would solve the problems faster for sure.

08-28-2011, 10:23 AM
Sorry but we have no experience with such a parallels configuration and we don't support Mac. But you should find other threads and descriptions how people solved this when googling for it.

08-28-2011, 12:11 PM
it def has nothing to do with mac. one of my friends had no problems with his HEM installation. you can pretend that i am using a normal windows7 and something went wrong with the SQL installation

08-28-2011, 05:31 PM
This is usually a firewall or windows update issue.

First try to reboot.

If no help, try this:

Start > Programs > PostgreSQL > 8.x > Stop Service

Start > Programs > PostgreSQL > 8.x > Start Service

If that doesnt help delete the \postgresql\8.x\data\postmaster.pid file, if you see it. And reboot.

If that doesn't help you will have to reinstall PostgreSQL completely
Try to install PostgreSQL: Choose a Mirror (http://wwwmaster.postgresql.org/download/mirrors-ftp/binary/v8.2.21/win32/postgresql-8.2.21-1.zip) to port 5433

08-28-2011, 10:46 PM

it seems like there is not postgresql version on my computer at all. cant find any folder.

i've tried to install it from your link. at some point it says: The 'secondary logon' serivce is not running. This service is required for the installer to initialize the database.
Please start this service and try again later.

Where can i find this service?

Maybe you can help me via teamviewer? would be more efficient..

08-29-2011, 01:16 AM
Hi, Please email support@holdemmanager.com with your availability and we will schedule you for a teamviewer.

08-29-2011, 09:38 AM
hi, thanks, i've just contacted your support

08-29-2011, 09:43 AM
You can read this http://forums.holdemmanager.com/manager-general/77881-how-configure-postgresql-ubuntu.html
possibly will find there some usefull info

08-29-2011, 09:59 AM
yea looks good. but its more than i want. i know from a friend that he had no problems at all doing what im trying to do with windows through parallels. for some reason almost no HEM installation on w/e machine has ever worked without problems for me. guess im running bad there

08-30-2011, 12:27 AM
Turn on the secondary Logon. The secondary logon service is a standard windows service which is available on every windows computer. In the latest versions it is not started automatically. You need to start it via control panel > administrative tools > services. Starting it once should insure it works in the future also.

08-30-2011, 07:04 PM
hi, thanks! all seems to work now. the logon wasnt active after a reboot but ive set it on automatic and i hope this will solve the problem