View Full Version : Postres problem

08-14-2008, 01:26 PM
Hi. I've tried searching various forums but I can't seem to find the answer to my problem. A few days ago I downloaded the trial version of HEEM and everything worked great. I had a problem where I has to do a system restore on my computer and that's where the problems started.

Let me start out by saying I am working in XP Home SP2.

I had to reinstall both HEM and Postres. HEM went fine but everytime I try to reinstall postres I have a problem. It won't recognize me as an administrator so it won't start the service during startup.

I've tried unistalling/reinstalling, eliminating all references to the program, but nothing seems to work. I love your program and would buy it, but I won't if I can't get the postres running.

Any ideas as to how to fix the problem?

08-14-2008, 02:58 PM
Youll need to post exact errors or screenshots of the problem for me to have an idea where to start. Firstly make sure you are logged on as an administrator if your using vista and have UAC disabled

08-14-2008, 04:24 PM
OK here we go (not good with screen shots). . .

First of all, using XP Home, not Vista. Turned off the Windows Firewall and my own firewall and virus protection(System Suite). My user type is administrator.

Upon launching the installer everything looks fine, I followed the setup exactly the way I had previously. This is as fresh an install as I can do, the folder and shortcuts have been removed as well as the program itself.

The setup extractor launches and everything is fine until it gets to the part where the downloader tries to start the service (very close to the end), at which there is a really long delay (green bar stops right at the left edge of the cancel button below it) and then a small new window launches above the installer that says:

"Service 'PostgreSQL Database Server 8.3' (pgsql-8.3) failed to start. Verify that you have sufficient privileges to start system services.

Retry Cancel"

If I hit retry, there is another long pause and the same window pops up again.

If I hit cancel, a box pops up that says:


Are you sure you want to cancel.

Yes No"

If you say yes, the installer says "Rolling back action". Basically unistalling the program. You have no buttons at all on the installer at this point (no cancel - NOTHING). The green progress bar starts to roll back. Eventually another box comes up saying:

"Fatal Error

Installation ended prematurely because of an error.


If you say no (to "are you sure you want to cancel"), it tries to start the service again with the same results.

IF I go to Administrative tools during the installation, it says the service is "starting" NOT "Started". During rollback it says "stopping". The startup type is automatic.

The failed installations leaves a "postgresSQL" folder with lots of folders and content inside in my "C> Program Files" folder. I also get a shortcut in my Start> All Programs Area with nine options as if the installation went smoothly.

In the services area, the services displays as "Stopping" like it is hung up.

That's the best I can do unless you know what else I should be looking for. I can't seem to figure out what to do next. Every uninstall/reinstall fails the same way.

08-15-2008, 01:14 PM
At the point where it stops can you follow the instructions on the FAQ to change it to "Log On locally" and see if that works.

Ive seen this problem before with 1 other person and i couldnt solve it. If the above approach dosent work id recommend posting in the postgreSQL forum though because they would have a better idea why it wont start the service.