PDA

View Full Version : Yet another PostgreSQL issue



forhdaisme
08-04-2011, 04:00 PM
I tried to install HEM a while back with no success. Back then it was a SQL issue - the same as now, I think:

http://img298.imagevenue.com/loc380/th_86940_ScreenHunter_01Aug.0421.51_122_380lo.jpg (http://img298.imagevenue.com/img.php?image=86940_ScreenHunter_01Aug.0421.51_122 _380lo.jpg)

- Since I tried earlier I've had a postgres user when I log in to windows and I just left it there in case I decided to try HEM again.

- I think my router is the main problem here. The block I live in is behind some router that has caused me problems connecting through some ports before.

So - is there a way I can change the port used for postgres or some other way around this?

Ps: tried this already the first time I tried to install:
http://forums.holdemmanager.com/manager-general/8182-fix-postgresql-cannot-start-error-127-0-0-1-a.html

Thx in advance!

Patvs
08-04-2011, 09:51 PM
This is usually a firewall or windows update issue.

First try to reboot.

If no help, try this:

Start > Programs > PostgreSQL > 8.x > Stop Service

Start > Programs > PostgreSQL > 8.x > Start Service

If that doesnt help delete the \postgresql\8.x\data\postmaster.pid file, if you see it. And reboot.


If that doesn't help you will have to reinstall PostgreSQL completely
Try installing a different version of PostgreSQL to a different port.

forhdaisme
08-05-2011, 08:21 AM
Thx for the reply.

Additional info: When the installer is trying to install postgres I get this error:
http://img159.imagevenue.com/loc475/th_45734_ScreenHunter_01Aug.0514.12_122_475lo.jpg (http://img159.imagevenue.com/img.php?image=45734_ScreenHunter_01Aug.0514.12_122 _475lo.jpg)
Ive made sure that the folder I install to isn't write protected and I've tried to install directly to C:\hem but with no luck.


~~~~~~~~~~~~~~~~


This is usually a firewall or windows update issue.

First try to reboot.

If no help, try this:

Start > Programs > PostgreSQL > 8.x > Stop Service

Start > Programs > PostgreSQL > 8.x > Start Service

If that doesnt help delete the \postgresql\8.x\data\postmaster.pid file, if you see it. And reboot.


If that doesn't help you will have to reinstall PostgreSQL completely
Try installing a different version of PostgreSQL to a different port.
Ive tried everything with no luck - but now the postgres user is gone when I start windows.

I didn't have a postmaster.pid file.

Edit: no wait, havent tried the "Try installing a different version of PostgreSQL to a different port". I have no clue how to do this, but googling as we speak!

forhdaisme
08-05-2011, 08:23 AM
btw, running vista, have tried to disable all security systems and win should be fully updated.

Thx for the help so far ;)

Patvs
08-05-2011, 08:35 PM
Install PostgreSQL: Choose a Mirror (http://wwwmaster.postgresql.org/download/mirrors-ftp/binary/v8.2.21/win32/postgresql-8.2.21-1.zip)
to port 5433.

Turn on the secondary Logon. The secondary logon service is a standard windows service which is available on every windows computer. In the latest versions it is not started automatically. You need to start it via control panel > administrative tools > services. Starting it once should insure it works in the future also.

forhdaisme
08-06-2011, 03:33 AM
Thx again for the reply, but no luck.
Tried to install again, but got this:
http://img141.imagevenue.com/loc516/th_615161934_ScreenHunter_01Aug.0609.30_122_516lo. jpg (http://img141.imagevenue.com/img.php?image=615161934_ScreenHunter_01Aug.0609.30 _122_516lo.jpg)

The secondary logon was already enabled.

netsrak
08-06-2011, 07:22 AM
Seems like you don't have the rights to create a user. Please try to start the installation as administrator

forhdaisme
08-06-2011, 07:45 AM
I dont get that option with the new postgres and when I do it on the HEM installer I get the same error.

forhdaisme
08-06-2011, 06:16 PM
I dont get that option with the new postgres and when I do it on the HEM installer I get the same error.

... the same error as in it wont install, not that I cant run as admin

Patvs
08-07-2011, 05:52 AM
Which Operating System, Firewall, and Anti-Virus are you using?

Please update to the latest beta - http://www.holdemmanager.com/Downloads/HmUpdate.exe

For W7 and Vista you must set \holdem manager\dbcontrolpanel.exe, holdemmanager.exe and hmhud.exe are started as administrator. Run the windows explorer and navigate to your Holdemmanager installation directory. Right click the executables and select properties... then select "Run as admin" from the compatibility tab.

Add exceptions to the windows firewall for holdemmanager.exe and hmhud.exe, even if the firewall is turned off. If you have a 3rd party firewall, do the equivalent or uninstall it temporarily.

Make sure your video card drivers and windows auto updates are fully updated. Make sure you have Microsoft .NET Framework 3.5 SP1 (or later for w7) installed.


Turn off User Account Control: Turn off User Account Control: How to Disable and Turn Off UAC in Windows 7 My Digital Life (http://www.mydigitallife.info/2008/12/30/how-to-disable-and-turn-off-uac-in-windows-7/) and reboot

netsrak
08-07-2011, 05:54 AM
Are you using any 3rd party firewall, anti-spyware, adaware, tuning or registry cleaning programs? and if yes which ones?

forhdaisme
08-08-2011, 06:44 PM
Thx for the reply :)
postgres is installed now - but I still cant get the trial to run? As before, the "try"-button is inactive. Do I have to register and enter a trial serial? (I doubt that - just making sure)



Which Operating System, Firewall, and Anti-Virus are you using?

I'm running vista, only using windows firewall and no anti-virus. However - as stated, I'm behind, what I think, is a rather strict router that I have no influence on.



Please update to the latest beta - http://www.holdemmanager.com/Downloads/HmUpdate.exe

For W7 and Vista you must set \holdem manager\dbcontrolpanel.exe, holdemmanager.exe and hmhud.exe are started as administrator. Run the windows explorer and navigate to your Holdemmanager installation directory. Right click the executables and select properties... then select "Run as admin" from the compatibility tab.

Add exceptions to the windows firewall for holdemmanager.exe and hmhud.exe, even if the firewall is turned off. If you have a 3rd party firewall, do the equivalent or uninstall it temporarily.

Make sure your video card drivers and windows auto updates are fully updated. Make sure you have Microsoft .NET Framework 3.5 SP1 (or later for w7) installed.

Done or was already done.



Turn off User Account Control: Turn off User Account Control: How to Disable and Turn Off UAC in Windows 7 My Digital Life (http://www.mydigitallife.info/2008/12/30/how-to-disable-and-turn-off-uac-in-windows-7/) and reboot

Done - this might have done the trick in allowing me to install postgres.

forhdaisme
08-08-2011, 06:47 PM
Are you using any 3rd party firewall, anti-spyware, adaware, tuning or registry cleaning programs? and if yes which ones?

Nothing that runs constantly. I use an online spyware scanner whenever I think it's needed. win defender takes care of the rest.

another question: will HEM2 require postgres aswell?

Patvs
08-08-2011, 07:49 PM
Yes HM2 (also PT4) will still use PostgreSQL.

forhdaisme
08-09-2011, 06:54 AM
Ok, otherwise I wouldn't keep wasting my time trying to get it to work ;)

netsrak
08-09-2011, 08:35 AM
If you still have problems Please schedule a remote support session with our support. Email support@holdemmanager.net, with a link to this thread and your forum name, so we can setup a Teamviewer (http://www.holdemmanager.net/teamviewer) session.