View Full Version : Cannot connect to HEM!

05-05-2009, 07:26 PM
First, I had the Vista SQL connection problem that a lot of people had not too long ago and spent countless hours using the info in various threads trying to resolve it. In the end I had to uninstall everything-Holdem Manager, Spybot, Avast and reinstall. I lost my database and had to reimport everything. Needless, to say I want to avoid this again at all costs.

Now, I'm having problems again. This is getting very frustrating. I dowloaded OpenOffice.org 3.0 which is a popular alternative to Microsoft Office:

Now I can't connect to Holdem Manager. I get the following messages:

When I start HEM a pop up box says: "The following error occurred when trying to open the database: Unable to read data from the transport connection: An existing connection was forcibly closed by the remote host."

I click OK and the UAC needs to be off box pops up-it is off.

I then try to connect to PostgreSQL and get the same message as above followed by a host of messages that say stuff like System.Net.Sockets.SocketException: a connectio was forcibly closed at System.Net.Sockets.Receive(Byte[]buffer,Int32 offset,Int32 size,SocketFlags socketFlags) at etc etc.

I see that OpenOffice.org uses SQL as well and (grrrrrr) has maybe caused the problem.

My questions are:
1. I need to use HEM, how do I connect?
2. Can 2 programs that both need SQL work together? I'd rather not ship $100+ to Microsoft just for Excel because I can't add my bonus and deposit information to HEM's reports.

I've already tried the basic stuff like rebooting and starting PostgreSQL in services-says started and then stopped. Some services stop automatically if they are not in use by other services or programs. Startup type:Automatic

Please help.

05-05-2009, 09:09 PM
Both can be used, i use it myself, the issue can be solved by following this thread http://www.holdemmanager.net/faq/afmviewfaq.aspx?faqid=34 which will lead to FAQ171 but its essential you follow every step exactly, if you dont youll just have to start all over again and it will take longer in the end, make sure you uinstall antiviruses/firewalls and not disable it as again it just wont work. The issue is caused by your firewalls/antivirus/vista blocking HM access to postgreSQL http://www.holdemmanager.net/faq/afmviewfaq.aspx?faqid=34

05-06-2009, 12:57 AM
Thanks for the help.

The solution wasn't as complicated this time:

I had to use the FAQ #171 referenced by you above. HEM,etc were already running as administrator with UAC disabled and exempted from firewall/defender. Since I did all the other steps already the trick was just to uninstall and reinstall Postgre SQL. I did have to delete the old database (again) and reimport all hands from hmarchive. That solved it.