View Full Version : add new database

07-25-2011, 05:25 AM
Can't get note caddy to work so decided to try starting from scratch and create a new database and reimport hands.
when doing so , i entered the new database name , hit return but the "ok" button was still greyed out. I had to click on the "..." button and then the "ok" button became active.

on a pedantic sidenote , would " Create new database" be better than "Ok"

07-25-2011, 02:56 PM
Does this happen often? I can't get this.

07-25-2011, 03:11 PM
it worked properly when i just tried to create a 3rd database. However , if make this the default database is unchecked the ok stays greyed out.

tried deleteing the 2nd database and creating a new 2nd one. worked ok. However, when i unchecked the make this the default database and type a random string of characters in the "ok" would sometimes grey itself out and then when some more letters were entered it would bold itself again.sometimes bolding and greying out every couple of characyters , and would do the same in reverse when characters were deleted.

07-25-2011, 03:15 PM
I can't get that to happen. I just tried 5-6 times and it shows the ok every time.

As far as the wording, I think it's pretty clear that OK means to create a new DB, and to add the text would make the button too long and look odd.

07-25-2011, 03:17 PM
do you want to do a quick teamviewer and see it in action on my computer

07-25-2011, 03:23 PM
think I've found the cause. typing in : or a space in the database name seem to do it

07-25-2011, 03:26 PM
in fact lots of non alphanumeric keys do the same thing. Can the input be filtered so that only allowable keys are recognised?

07-25-2011, 03:34 PM
Just the basic alpha-numeric characters are acceptable - that's why the ok is grayed out.

07-26-2011, 04:15 AM
the database name is essentially just a filename though , so wouldn't it be more intuitive to follow filename naming convention . Also how does this affect non english speakers who may want to use non alphanumeric characters accents,umlauts etc..

07-26-2011, 08:59 AM
The database name is NOT just a filename. Its the name handled by the postgresql database server which doesn't accept special characters. Nothing we can do about it.

07-26-2011, 09:15 AM
What can be done though is to prevent those special characters from being entered in the database name. By accepting the characters in the data field but greying out the OK its not obvious why it can't be accepted.