View Full Version : SQL function missing?

04-30-2009, 10:35 AM

I've recently installed HEM 1.07 and have imported my PT3 database completely. Then I upgraded to 1.08 with Omaha support and have also imported my PTO database.

Since the 1.08 upgrade I have troubles accessing my hand histories from HEM.
The "Cash Game -> Hands" tab is completely empty and when I capture the SQL query and try to run it myself, I get the following error message:

ERROR: function getwinningplayerjoincashver2(integer) does not exist
HINT: No function matches the given name and argument types. You may need to add explicit type casts.

Is there a quick fix that recreates the postgres layout without touching the actual data or do I need to reimport all hands in a fresh database with HEM 1.08?

04-30-2009, 06:57 PM
Looks like youll need to reimport, just test first with a couple of hands into a new database and if the problem dosent reoccur the reimport all hands

04-30-2009, 07:35 PM
Thanks but it's still not working.

I've closed HEM, dropdb'd the hem database and started HEM.
I get a message box with the postgres error message that the hem database couldn't be opened, then HEM takes me to the postgres configuration dialog where I click "Connect", "Create New Database" and then "Start HoldemManager" with the newly created database selected and marked as default. The next message box says "Holdem Manager is making an update to your database. Please click ok and be patient - this should not take long" and the next one says "Holdem Manager is making an update to your database that will enable the importing and analysis of Omaha hands. Please note that the Omaha module is an add-on and is currently in beta".

Then I've imported a few hundred PLO400 and HA200 hands, selected me as Player and the "Cash Games" -> "Hands tab" stays empty still.

And when I try the query myself, I still get the missing function error message.

04-30-2009, 08:16 PM
Can you email me some of those hands and also link to this thread morny@holdemmanager.net

05-05-2009, 01:05 AM
If this is still a problem please install www.teamviewer.com and email me at support@holdemmanager.net so I can take a look. For some reason your DB is not wanting to create a needed function and I have not seen this before. If I have access to it I should be able to 1) figure out why it is happening and 2) fix it for you