Poker Software
Results 1 to 4 of 4
  1. #1
    Junior Member
    Join Date
    May 2009
    Posts
    6

    Default Trouble restoring database

    I got a new comp with windows 7 and I am trying to use my database from my other computer which I backed up onto an external hard drive.

    On the new comp I first installed postgresql, making sure I unselected 'Initialize Database Cluster' in step 10 of http://www.holdemmanager.net/faq/afm...aspx?faqid=177

    Now I am trying to follow these instructions to select my old database http://www.holdemmanager.net/faq/afm....aspx?faqid=12

    Step 4 of the later link is: '4) In pgAdmin, click on Edit > New Object > New Database. A New Database dialog will pop up'

    I am unable to click 'New Object' because it is greyed over. Any suggestions?

    Thanks!

  2. #2
    HM Support netsrak's Avatar
    Join Date
    Feb 2009
    Location
    Germany
    Posts
    25,146

    Default

    When trying to restore a database from a backup you need a running cluster.

    This option is only obsolete when you want to use a data folder from a previous postgresql installation.

    Start the installation of postgresql again, initialize the cluster, create an empty database and restore again.
    Participate in the Alpha release of the newest Hold'em Manager version: HM Cloud. Sign-up HERE.

    If you would like to leave some feedback to help us improve the quality of the solutions, and/or the support quality you received, - you can do this here
    <center><hr/>
    HM2 FAQ -- Quick Start HM2 Guide -- Licensing -- Postgresql issues -- Top 10 Performance Tips<hr/></center>

  3. #3
    Junior Member
    Join Date
    May 2009
    Posts
    6

    Default

    Ok I am attempting to start the installation again, however I am getting the error message : "data directory already contains a postresql databes of this version..."

    so I followed these instructions

    You must *fully* remove PostgreSQL if you want to install it again.

    1. Uninstall from control panel. add/remove programs
    2. manually delete the Program Files\Postgresql folders
    3. run the command (no quote marks) - start > run > 'cmd' > "net user postgres /delete"
    - reboot.
    On the third step i get 'Access is denied'

    I have been trying to install HEM and import my old database for 2 days now... I'm searching every forum etc but running into problem after problem...ugh!

  4. #4
    Graphics Guru fozzy71's Avatar
    Join Date
    Sep 1971
    Location
    HM Support
    Posts
    24,298

    Default

    For reinstalling SQL to a new/empty DB, please follow these steps:

    1) Uninstall PostgreSQL from the Windows Control Panel.
    2) manually delete or rename the Program Files\Postgresql folders
    3) run the command - start > programs > accessories > command prompt > right-click > run as administrator
    PHP Code:
    net user postgres /delete 
    4) reboot.
    5) Install PostgreSQL 8.4, with your firewall uninstalled or turned off if windows firewall - http://www.enterprisedb.com/products...oad.do#windows
    Participate in the Beta release of the newest Hold'em Manager version: HM Cloud. Sign-up HERE.

    If you would like to leave some feedback to help us improve the quality of the solutions, and/or the support quality you received, you can do so here: Leave Feedback

Similar Threads

  1. Trouble with restoring Database
    By Rookie72 in forum Manager General
    Replies: 1
    Last Post: 10-04-2009, 08:29 AM
  2. restoring database on 2nd computer
    By djfl in forum Manager General
    Replies: 14
    Last Post: 07-17-2009, 07:01 AM
  3. Problem with restoring the database
    By tizzl in forum Manager General
    Replies: 1
    Last Post: 05-12-2009, 02:34 PM
  4. New PC: Restoring database & registration
    By eendje01 in forum Manager General
    Replies: 8
    Last Post: 01-15-2009, 06:50 PM
  5. Need help restoring database
    By osiris873 in forum Manager General
    Replies: 5
    Last Post: 10-21-2008, 09:06 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •